Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #348590 Score: 0
    Profile photo of kirsten carnahan
    kirsten carnahan
    Member
    beginner
    intermediate
    friend finder
    Group Member
    picture perfect
    curious george
    wise owl
    @kcarnahan9421

    Hello, I am trying to trouble-shoot a course I just published in our LMS. I can’t identify what is causing the error but here is what is going on. I am using actions and variables to track the navigation and allow users to progress to the summary page. We have had 2,200 users complete the course without any errors. But approximately 60 people have gotten stuck on the page where I am tracking the variables to allow them to progress. Basically the next button is not showing in these 60 error cases. I can’t find a common theme that would cause intermittent errors like this. From what I can tell the users getting errors are all within our corporate network on the standard PCs with the standard browser which is IE in this case. I have also viewed the course in chrome and I can’t duplicate the error.

    Does anyone have any suggestions for me to troubleshoot and hopefully find out what might be causing the page not to display the next button for 60 out of 2 thousand plus users?

    Thank you, Kirsten

    #348597 Score: 1
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    57 pts
    @mnotermans5114

    Hi Kirsten,

    Is the next button hidden on that page when it shows?
    And is there a specific condition set to show the button?
    What version of IE are you using?
    What browser do the users that succesfully can continue use?
    Any IE users among them? And which version of IE they use?
    Are the IE users that can continue also inside your corporate network or outside?

    A few questions that might define the issue. Firewall, version of IE, IE-addons, IE-compatibilitymode are a few of the things im thinking of.

    You could run a test outside your corporate network to see whether its the network itself that somewhere limits it.

    Not sure whether there are secure or delicate elements in the course, but if you can share it, i gladly take a look into it.

    Kind regards,

    Math

    This post has received 1 vote up.
    #348665 Score: 0
    Profile photo of kirsten carnahan
    kirsten carnahan
    Member
    beginner
    intermediate
    friend finder
    Group Member
    picture perfect
    curious george
    wise owl
    @kcarnahan9421

    Hello,

    Thank you for the suggestions. I will look at those things.

    Is the next button hidden on that page when it shows?
    And is there a specific condition set to show the button?

    • Correct it is hidden and once the users views 7 tracks or branches, the last page of each of the tracks adds to a variable. Then when they come back to the selection page where the nest button is hidden (or map page in my case). The action on page load should trigger the next button to show if the variable is = or greater than 7. Which takes them to the summary page to complete the course.

    What version of IE are you using?

    • IE 11, which is our standard that IS pushes out to everyone.

    What browser do the users that successfully can continue use?

    • The majority are using IE 11. But Chrome is also successful. As is Firefox and Safari. In addition people have successfully completed it on apple and galaxy phones and tablets.

    Any IE users among them? And which version of IE they use?
    Are the IE users that can continue also inside your corporate network or outside?

    • Yes, they are inside the network. But I have also tested it outside and can not re-create the error.

     

    The course is very large., I will try to piece out the track giving the error and attach. I sincerely appreciate your help!

    Thank you, Kirsten

    #348675 Score: 1
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    57 pts
    @mnotermans5114

    You might wanna check IE compatibility mode. On several LMS i encountered that for some reason the IE compatibility mode was lowered to a older version of IE ( below 10 ) then a lot of Lectora’s functionality didnot work anymore. Only thing that confuses me, is that for some users it does work and for others not…so what are those doing differently ?

    This post has received 1 vote up.
    #348735 Score: 0
    Profile photo of kirsten carnahan
    kirsten carnahan
    Member
    beginner
    intermediate
    friend finder
    Group Member
    picture perfect
    curious george
    wise owl
    @kcarnahan9421

    I agree, it is confusing that it’s such a small sampling of users that encountered the error. I will do my best to look into the compatibility mode. It’s always possible that folks have different configurations out there. There is just no way to know of every possible config. Thanks again for the help! I’ll let you know what happens.

    #348753 Score: 1
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    133 pts
    @Klaatu

    Kirsten, you didn’t by any chance add ANYTHING other than strict meta-data in a meta tag? There are some on this forum who think it is okay to add scripts and styles this way but they are wrong (There’s appropriate methods for those). With everything web related, Order matters. The edge mode compatibility tag must be in the head of the document and only other meta-tags (with strict META-DATA) and the title tag can go above it or it will not work (it is suggested to put it first just below the head tag so it is the first instructions after the doctype). There are some other stipulations too, like not having conditionals above it. When you add a meta-tag using Lectora it puts the content above the other meta-tags, so if you drop in a script or style in this way, you break the compatibility mode instruction. See the MSDN page for specifying legacy document modes.

    I”m curious to know what mode the computers that do not display correctly are running. Ask the users to open the developers console (hit F12) and look to the right. In the black menu bar there will be an icon of a monitor and mobile device with a number and a down icon. The number displayed is the mode the browser is using to display that page.

    Companies often run Intranet sites in lower compatibility modes due to the need to run legacy third party software that breaks under newer versions (Math, this is probably the reason behind those LMS that change the mode – bad programming). Compatibility mode can be set from the server (best way), from the HTML document using the meta-tag approach, or locally on the computer via Internet Explorer settings.

    Changing the compatibility mode via meta-tag will not override a local compatibility setting on the computer, however, setting it via the server will. There is some good info here as well.

    IF this is a compatibility mode issue then I would guess it is set on the individual machines to be different from the others or it would not work on any Intranet connected computer, right? Can those having issues with IE try to run Chrome instead as a test?

    Improperly coded iframes using quirks mode can also cause issues as outlined in this CSS-Tricks article for those that may be interested.

    An0ther MSDN article may be of help is about Meta-Tags and locking in future compatibility.

    One more (Hey, I use these posts as references too) – How to forcefully set IE’s compatibility mode to off from the server side?

     

    This post has received 1 vote up.
    #348819 Score: 0
    Profile photo of kirsten carnahan
    kirsten carnahan
    Member
    beginner
    intermediate
    friend finder
    Group Member
    picture perfect
    curious george
    wise owl
    @kcarnahan9421

    We have had some success with changing the compatibility mode today in IE. I have a few more folks helping us test. Maybe that is the culprit. Thanks again for all of the info, gentlemen.

    #349782 Score: 0
    Profile photo of kirsten carnahan
    kirsten carnahan
    Member
    beginner
    intermediate
    friend finder
    Group Member
    picture perfect
    curious george
    wise owl
    @kcarnahan9421

    We are still experiencing some errors. I noticed when I am looking at the developers console that there is an error on my page. The error is: SCRIPT1002: Syntax error  Line: 1, Column: 99

    Does this help? I am looking through the code, but I can’t find anything that seems to be an error to me. But I am not a coder.

    Would attaching the code file help?

    #349795 Score: 0
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    57 pts
    @mnotermans5114

    If you can share a complete Lectora .awt would be best. Then me and possible some other helpfull community members can test it. I can imagine you are not allowed to share it as is. Get rid of anything not relevant for testing. I would gladly help, but without a title to test it is tough to pinpoint.

    Regards,
    Math

    #349979 Score: 0
    Profile photo of kirsten carnahan
    kirsten carnahan
    Member
    beginner
    intermediate
    friend finder
    Group Member
    picture perfect
    curious george
    wise owl
    @kcarnahan9421

    Hello, The course files are attached. I took out the pages before the section in question. The page that you start on, is the “Map” page then you go to all of the 7 scenarios returning to the map page each time to see that the check marks show the complete scenarios until they are all complete. When they are all showing the final text should fly in along with the next button.

    The intermittent error I am seeing is  some of the time the final text is not showing as intended triggering the next button.

    I pulled out most of the video resources so some of the buttons will open blank pages. FYI

    Thanks again, Kirsten

    Attachments:
    1. course.zip
    #350191 Score: 1
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    57 pts
    @mnotermans5114

    Hi Kirsten, downloaded and will test and upload it on my LMS tomorrow. Let you know what and if i find anything specifc.

    Regards,
    Math

    This post has received 1 vote up.
Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.