Explore the community Forums Lectora Lectora Questions & Answers MP4s not playing on Moodle LMS

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #346830 Score: 0
    Profile photo of Adriana7707
    Adriana7707
    Member
    beginner
    intermediate
    curious george
    contributor
    wise owl
    @Adriana7707

    Hi,

    I have an issue with MP4s not wanting to play on Moodle LMS. It gives the error message Plugin not supported. The guys at the company that runs Moodle says I must remove the flash file. How on earth do I do that? What puzzles me is that some of the mp4s work and some don’t. They say the problem is when importing them into Lectora or the settings. I think the problem is on their side.Has anyone experienced this problem? It didn’t do it on other LMS platforms.

    #346862 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    181 pts
    @timk

    I’m using mp4s in moodle 3.0 and they play without any issues.  Do you use different skins for the different videos?

    Can you share one of the videos that don’t play? I could test it in moodle to see if it plays.

    #347105 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Moderator
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    98 pts
    @jvalley4735

    Are you using one of the players provided within Lectora or a custom one?

    #347134 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    181 pts
    @timk

    and which version of Lectora do you use? – above or below 16.1?

     

    #347459 Score: 0
    Profile photo of Adriana7707
    Adriana7707
    Member
    beginner
    intermediate
    curious george
    contributor
    wise owl
    @Adriana7707

    I’m using Lectora 12.1.4.
    I import them normally. No skins. It’s standard.
    Here is a download link of the scorm files
    https://www.dropbox.com/s/ff41bamko98l1wn/ABC_BLSS.zip?dl=0</p&gt;

    • This reply was modified 2 months, 3 weeks ago by Profile photo of Adriana7707 Adriana7707 .
    #347466 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    181 pts
    @timk

    Lectora 12 uses JW Player, which normally uses flash to play videos. You can try to use this:

    http://community.trivantis.com/shared-content/use-html-5-media/

     

    #350574 Score: 0
    Profile photo of Adriana7707
    Adriana7707
    Member
    beginner
    intermediate
    curious george
    contributor
    wise owl
    @Adriana7707

    Thanks so much. How do I use it? I still have so much to learn…

    #350580 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    181 pts
    @timk

    Click on “Download Lectora file”. What you’ll get is a Lectora Library Object (.awo). Select an element on title level and drop the file onto the page. It will reveal an HTML extension with code that is supposed to force the player to prefer HTML 5 video before the flash player.

    Sorry, I’m not exactly sure whether it will solve the issue…

    Tim

    #353003 Score: 0
    Profile photo of Adriana7707
    Adriana7707
    Member
    beginner
    intermediate
    curious george
    contributor
    wise owl
    @Adriana7707

    Hi Tim,

    They finally tested it and it still doesn’t work. I don’t know what else can be done. Any other ideas?

    #353021 Score: 0
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    57 pts
    @mnotermans5114

    Hi Adriana,

    You have to make sure flash aint used when playing video. If i can help by changing a Lectora file and show you how to.. i gladly will.

    Regards,

    Math

    #353023 Score: 0
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    133 pts
    @Klaatu

    “What puzzles me is that some of the mp4s work and some don’t.” – How are you encoding the MP4’s?

    “It gives the error message Plugin not supported.” – Is ‘Plugin not supported’ the only thing it says? Can you be more specific, maybe include a screenshot?

    Because you mentioned that some video’s work and some do not, I think your best bet is to re-encode the video with something like Freemake Video Converter (FREE). Just use caution while installing it so you don’t accidentally install all the bloatware included in the installation process (because the program is free). I have never had an issue in Lectora with a video encoded with Freemake.

    By the way, JWPlayers default rendering mode is html5.

     

     

     

    #353469 Score: 0
    Profile photo of Adriana7707
    Adriana7707
    Member
    beginner
    intermediate
    curious george
    contributor
    wise owl
    @Adriana7707

    Thanks so much, I will try doing the mp4s differently. I did not do it originally, so not sure how the previous person did it. When I come right I will let everyone know what worked and possibly what the issue was.

    #353471 Score: 0
    Profile photo of Adriana7707
    Adriana7707
    Member
    beginner
    intermediate
    curious george
    contributor
    wise owl
    @Adriana7707

    Hi Math,

    I have spend hours trying to figure out how to do that. It would be great if you can show me, if it works, then I don’t have to convert all those mp4s again. Please take note that I do not have the latest Lectora. I’m using Lectora 12.1.4.

    #353474 Score: 0
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    57 pts
    @mnotermans5114

    I dont use version 12 myself, but do have version 11 and before. If i got some time i create a sample you can use to test, and if that works use the same approach on your videos.

    Regards,

    Math

    #353530 Score: 0
    Profile photo of Adriana7707
    Adriana7707
    Member
    beginner
    intermediate
    curious george
    contributor
    wise owl
    @Adriana7707

    Thank you. I’m going to add a button with a link to YouTube in the meantime and see if that can be a temporary solution.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.