Explore the community Forums Lectora Lectora Questions & Answers iOS: fullscreen video ignores JavaScript in player? Reply To: iOS: fullscreen video ignores JavaScript in player?

#443053 Score: 0
Profile photo of CarlFink
CarlFink
Member
beginner
intermediate
contributor
LUC16 Attendee
wise owl
curious george
advanced
friend finder
41 pts
@CarlFink

Joe:

First, thanks for the response.

  1. There is no button labeled “code” in this window. I could go into the “Text” mode (which really means “type in HTML tags yourself” and that’s a very poor description, and yes, I know you inherited it from WordPress) and use my own tags, but really? Or did you mean to use the Preformatted text style?
  2. Extensions of type Cascading Style Sheet, at least in the current Lectora in my installation, do not let me enter anything, only select a file. I created a file named no_video_controls.css and selected that, containing your code. It had absolutely no effect when I published as HTML, so I published to ReviewLink, where it also had exactly no effect whatsoever. Testing in Google Chrome, a version a couple of months old, and Internet Explorer 11.

I realized that I could just switch to “Controller: None” and remove all native controls, even in full screen on iPadOS. That will be my short term solution while I fight with this. (If you had a “full screen” action in Lectora, I would be fine. Volume control can be handled at the OS level.)

Maybe I’ll try creating my own controller skin. There’s an option to import custom skins as Zip files. Are these documented anywhere?