Explore the community Forums Lectora Web Accessibility Alt Tags not Showing

Tagged: 

Viewing 11 posts - 16 through 26 (of 26 total)
  • Author
    Posts
  • #433886 Score: 1
    Profile photo of Ann Sisco
    Ann Sisco
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    contributor
    profile
    picture perfect
    8 pts
    @prg1792

    Hi, Monica (@mspencer.2813)

    To attach the JS file to your title, perform the following steps:

    1. Select the Insert ribbon.
    2. Way over on the right, select Attachment.
    3. A window will open. Navigate to the folder where you saved your new JavaScript file.
    4. Select the file.
    5. Select Open.

    The JavaScript file is now attached to your title. You can verify this by selecting the Tools ribbon, then Resources. The file should be listed under Attachments/Other.

    When a file is attached to a title, it is copied into the root folder of the published files each time you publish. If it is not attached, it is not copied into this folder, and you will get an error message for any corresponding JavaScript calls.

    Hope this helps.

    This post has received 1 vote up.
    #433890 Score: 1
    Profile photo of Ann Sisco
    Ann Sisco
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    contributor
    profile
    picture perfect
    8 pts
    @prg1792

    @mspencer.2813

    I just published my test title in v18.2.1 using the code I had posted. It is not working with this version. I’ll have to dig a bit to see what changed since I posted my example. Sorry!

    UPDATE: Be sure that any smart quotes are replaced with straight quotes both in the code of your new JavaScript file and in the HTML Extension text. That’s what caused my recent attempt to fail.

    This post has received 1 vote up.
    • This reply was modified 12 months ago by Profile photo of Ann Sisco Ann Sisco.
    #434044 Score: 0
    Profile photo of Monica Spencer
    Monica Spencer
    Member
    beginner
    intermediate
    wise owl
    friend finder
    contributor
    @mspencer.2813

    @prg1792

    Thank you, Ann! I replaced the smart quotes with straight quotes in both the js file and the HTML extension text and it WORKED!!!

    Thanks for the script, explanations, clarification, and quick response. It was all very helpful!

    #434047 Score: 1
    Profile photo of Ann Sisco
    Ann Sisco
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    contributor
    profile
    picture perfect
    8 pts
    @prg1792

    You’re welcome 🙂 Glad that worked for you!

    This post has received 1 vote up.
    #445838 Score: 0
    Profile photo of Monica Spencer
    Monica Spencer
    Member
    beginner
    intermediate
    wise owl
    friend finder
    contributor
    @mspencer.2813

    *Sigh* This script doesn’t seem to work anymore for Lectora 19, based on preliminary testing of another course in SCORM Cloud.

    It would be nice not to scour the Internet for work-arounds every time there’s a Lectora update.

    Does anyone have a fix for the ARIA text or ALT text not showing on keyboard tab for sighted users in Lectora 19?

    #445847 Score: 0
    Profile photo of Ann Sisco
    Ann Sisco
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    contributor
    profile
    picture perfect
    8 pts
    @prg1792

    Hi Monica @mspencer-2813

    I manually inserted the code into a course I published with the Lectora v19 Beta. I’ll add this disclaimer: since I did not publish using the official v19 application, I cannot say with 100% confidence that my results reflect that tool.

    That said, I can see that the code is still correctly taking the alt value (for images) and the aria-label value (for buttons) and setting the title attribute, which is visible on mouse-over. I looked in IE 11, Chrome, and Firefox using the Developer Tools F12 option for each and see that this change has been made.

    I am able to see a “tooltip” when moving the mouse over a button or image in all three of these browsers.

    But, I only saw the “tooltip” on keyboard focus using IE 11. Chrome and Firefox do not display the tooltip on keyboard focus.

    Looking online, I see that the lack of support for displaying the title attribute on keyboard focus is listed as bug for Chromium, with no resolution: https://bugs.chromium.org/p/chromium/issues/detail?id=829352

    And another site explains why this makes the title attribute unreliable: https://developer.yoast.com/blog/dont-rely-title-attribute/

    So, I’m guessing that what you are experiencing is not related to Lectora v19, but the browser. Could you confirm if you see the tooltips in IE 11 or Edge?

    #445851 Score: 0
    Profile photo of Monica Spencer
    Monica Spencer
    Member
    beginner
    intermediate
    wise owl
    friend finder
    contributor
    @mspencer.2813

    The browser I need it to work in is IE 11 (yay, government). That’s where it worked before.

    EDIT:

    I’ll try entering it manually and see if that fixes the issue.

    #445855 Score: 0
    Profile photo of Ann Sisco
    Ann Sisco
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    contributor
    profile
    picture perfect
    8 pts
    @prg1792

    Ok. Here are a couple tests for you to try:

    1. When running in SCORM Cloud in IE 11, do the tooltips appear when you mouse-over?
    2. Within Lectora, if you preview a page in the IE 11 browser, do you see the tooltips on mouse-over and keyboard focus?
    3. If you publish the course as just “Web” instead of “SCORM”, do you see the tooltips on mouse-over and keyboard focus?

    If the first answer is “no” but the other answers are “yes”, then it’s possible that the Lectora v19 SCORM wrapper has changed in some way preventing the code from executing when deployed as SCORM.

    #445858 Score: 0
    Profile photo of Monica Spencer
    Monica Spencer
    Member
    beginner
    intermediate
    wise owl
    friend finder
    contributor
    @mspencer.2813

    OK, never mind. I just did it again and it works!

    I think I screwed something up by adding a second HTML extension by mistake. Maybe they canceled each other out. So I deleted it and now it’s working again.

    Thank you again for your quick responses and insights. I do appreciate it!

    #445860 Score: 0
    Profile photo of Ann Sisco
    Ann Sisco
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    contributor
    profile
    picture perfect
    8 pts
    @prg1792

    Great to hear that you got it working again 🙂

    I will add that it is important to always test any custom code whenever there is a Lectora update. You never know what an update will do.

    #452172 Score: 0
    Profile photo of Christine O'Malley
    Christine O’Malley
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    advanced
    contributor
    product reviewer
    LUC17 Attendee
    Group Member
    11 pts
    @comalley5856

    By request of one of our group members, this topic has been added to the agenda for the October 29, 2020 Lectora Accessibility User Group open discussion.

    If the folks who participated in this string – or anyone else interested, would like to join that discussion, please go to http://www.thelaug.org to add your name to my email distribution list. This will ensure you receive an invitation to our meeting (which takes place the last Thursday of every month (Jan-Oct) from 10:00 – 11:15 Central).

Viewing 11 posts - 16 through 26 (of 26 total)

You must be logged in to reply to this topic.