Explore the community Forums Lectora Lectora Questions & Answers Audio won't play in Preview mode, but plays fine when course is published

Tagged: , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #301143 Score: 0
    Profile photo of lydonk
    lydonk
    Member
    beginner
    intermediate
    @lydonk

    I am using Lectora 12 and Internet Explore (IE) v11. I cannot get the audio to play when I run my courses in Preview mode. The audio works fine when I publish the courses to the LMS. When I preview my courses through the browser, Google Chrome plays the audio and IE does not. Trivantis support says it is a security setting in IE since Preview mode uses IE. I have played around with the IE Security settings but have not had any luck. I had the same issue with IE9. I believe this all started when I upgraded to Lectora 12. Does anyone have any ideas on how I can resolve this audio issue for Preview mode only?

    #301160 Score: 2
    Profile photo of Sergey Snegirev
    Sergey Snegirev
    Member
    contributor
    intermediate
    advanced
    friend finder
    lab member
    junior moderator
    advocate
    LUC16
    LUC16 Attendee
    wise owl
    335 pts
    @ssneg

    When previewing in a browser, Lectora publishes the page locally to your hard drive and opens in in a browser (chosen by you). All and any browsers treat HTML pages on your hard drive as a security risk and will therefore block certain functionality, thereby messing up how the page is displayed. What works and what doesn’t (and how it affects your page) is always a bit of mystery. I had problems with Chrome for example when half of my JS code would run OK and another half was blocked for some reason.

    In Microsoft speak, pages that are located on your hard drive are in the “My Computer Security Zone”, here’s some information about that – https://support.microsoft.com/en-us/kb/174360. You will need admin privileges (and quite a bit of tinkering) to set up less restricting permissions for that zone.

    This post has received 2 votes up.
    #301168 Score: 0
    Profile photo of lydonk
    lydonk
    Member
    beginner
    intermediate
    @lydonk

    What you say makes a lot of sense. I read the article you included, but I am not clear on how to access the My Computer security settings. Can you provide further guidance?

    Thanks,

    Kevin

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.