Explore the community Forums Lectora Lectora Questions & Answers Audo and media player skins missing – can't add either

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #341674 Score: 0
    Profile photo of The AV-ator
    The AV-ator
    Member
    advanced
    contributor
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    profile
    picture perfect
    Group Member
    12 pts
    @TheAv-ator

    So I’m having an issue where I only have 1 default audio player skin. None of the standard default ones show up in my list, and the link/button to click to add a new skin is missing as well. So not only do I not have different skins to choose from, I can’t any new ones either.  This was on Lectora inspire 16, I updated to Inspire 17 today and everything is still missing.

    The other developer sitting next to me has the same versions and his is working perfectly(on identical computer systems as well). We even went in to our Programs folder and compared those and they’re almost identical (with the exception of a couple extra custom skins he created showing in his folder).

    Anyone have any ideas???
    Screenshot of my controller selection is attached

    Lectora Inspire V16 & V17
    Windows 7 Enterprise x64
    Dell Precision T7810

    #341680 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    114 pts
    @jvalley4735

    Did you install as an administrator?

    Lectora Installation Checklist and Instructions

    #341765 Score: 0
    Profile photo of The AV-ator
    The AV-ator
    Member
    advanced
    contributor
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    profile
    picture perfect
    Group Member
    12 pts
    @TheAv-ator

    So I uninstalled and had our IT install as directed by the checklist and then restarted.

    No dice… still only the default player and no option to load a new one. I re-verified the location for the skin files and such. Everything looks correct, but still not workin’ right.

    Attached are pics of the mediaplayer folder and skins folder – everything looks to be in place unless you see something out of the ordinary

    Any other thoughts or things to check?

    • This reply was modified 2 years, 9 months ago by Profile photo of The AV-ator The AV-ator.
    #341774 Score: 2
    Profile photo of The AV-ator
    The AV-ator
    Member
    advanced
    contributor
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    profile
    picture perfect
    Group Member
    12 pts
    @TheAv-ator

    AHA! I figured it out…

    Under Title Options, if you have Use Web Accessibility Settings checked it limits you to only that one player. If you uncheck that option all the skins return as options.

    Shouldn’t all the new skins meet those guidelines though? Aren’t they all CSS and not Flash based anymore?
    Is there any way to make a more custom skin that meets those requirements?

    Thanks!

    This post has received 2 votes up.
    #342081 Score: 1
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    114 pts
    @jvalley4735

    When we first switched everything over we wanted to limit risk by only offering the default player.  In future versions of the product the other default player skins will also become available.

    This post has received 1 vote up.
    #400143 Score: 0
    Profile photo of Christine O'Malley
    Christine O’Malley
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    advanced
    contributor
    product reviewer
    LUC17 Attendee
    4 pts
    @comalley5856

    I’ve had the same issues in the past and was able to resolve with some CSS – and as you say the Accessibility setting. Thanks for the reminder on that!

    I am currently experiencing an issue where the textblock (for the CC) was somehow corrupted. As a result, I cannot change the width of the captions box for the audio controller. For example, the width of the controller is 615 pixels but the width of the text within the controller is only 300 pixels wide.

    I’ve looked at the CSS which is supposed to control the text aspect of the controller but changes to the CSS are not having any effect. Even though I point to the updated CSS file and removed any old (audio controller) CSS from the extern folder.

    The good news is that I am successful in swapping out the (corrupted?) audio controller for a wider one which includes a matching wide text block – and the VTT will show correctly. However, the challenge in going this route is that any audio events are not transferring over when the clip is associated with the new audio controller.

    Any suggestions? Trying to prevent having to re-insert audio events for an entire module.

    Thank you kindly,
    Christine

    #400257 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    picture perfect
    45 pts
    @JasonADal

    @comalley5856 – Did you update the attributes for the captions layer? I discovered that the !important was necessary to get it to work correctly.

    div[class=”mejs-captions-layer mejs-layer”] {
    width: 340px !important;
    background: #000;
    }

    This allows you to change the properties for the layer itself. It sounds like you have the div for the captions text, which is different:

    div[id^=”audio”] .mejs-captions-text {
    padding: 3px 5px;
    background: #000;
    white-space: pre-wrap;

    }

     

    #400267 Score: 0
    Profile photo of Christine O'Malley
    Christine O’Malley
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    advanced
    contributor
    product reviewer
    LUC17 Attendee
    4 pts
    @comalley5856

    I will take a look at that and post if this resolved the issue or not.  Thanks Jason!

    #400299 Score: 0
    Profile photo of Christine O'Malley
    Christine O’Malley
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    advanced
    contributor
    product reviewer
    LUC17 Attendee
    4 pts
    @comalley5856

    Hi Jason,  what you’re saying makes sense to me. Not being a CSS guru, I’m not sure if maybe something isn’t correct in the css file. I am attaching a copy of it. Would you mind taking a look? I’m pointing to this css file in the course, but no change.

    #400342 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    picture perfect
    45 pts
    @JasonADal

    That was my bad, Christine – It’s actually the captions-position that changes the width, alignment, etc:

    div[id^=”audio”] .mejs-captions-position {
    position: absolute;
    width: 600px;
    bottom: 15px;
    text-align: left;
    }

    This should update the width of the caption line along with align it to the left. If you change the “bottom” it will raise and lower the line – I still struggle with the “top-down” in CSS because I know just enough to be dangerous. 🙂

    I tested this applying it to the default player, so there may need to be other mods made – Is the controller and skin already at the width and height you want it? If so, then the above should work wonders. Also, the .mejs-container line is missing a } – That MAY be affecting it, too.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.