Explore the community Forums Lectora Lectora Questions & Answers Basic SCORM course to xAPI, help!

Tagged: ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #311979 Score: 0
    Profile photo of Raphy Abano
    Raphy Abano
    Member
    beginner
    intermediate
    contributor
    @rabano9900

    Hi everyone,

    So I built this basic course for SCORM, but for some reason when I publish it for TinCan it doesn’t seem to work.

    Inside the AWT in the zip file I attached, you’ll see that I created a page with a question (not a test), and then the last page is a summary with an action to set AICC_Lesson_Status to “Passed”. When I publish this to SCORM and uploaded to SCORM Cloud it works fine, but when I publish to xAPI, it’s not completing.

    Any idea on what else I need to do in order for this to work? I was told that for as long as I have it set up like SCORM, it should work fine as TinCan.

     

    Thanks.

    #311987 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    113 pts
    @jvalley4735

    Are you publishing the xAPI version to Scorm Cloud? Sometimes different LMS’s use different words to pass completion.  Are you able to see if the action is even being fired in the browser when published to xAPI?

    #312006 Score: 0
    Profile photo of Raphy Abano
    Raphy Abano
    Member
    beginner
    intermediate
    contributor
    @rabano9900

    Hi Jennifer,

     

    Yes, I did. I actually included an action to set CMI_Completion_Status to “Completed”, published again as xAPI and uploaded it to SCORM Cloud.

    I’m also seeing LRS statements as I navigate through the course – and whether I set both AICC_Lesson_Status or CMI_Completion_Status as completed or passed, Scorm Cloud isn’t giving me the completion status.

    So yeah, I’m wondering if I built it wrong or if there’s something else I need to setup on the file.

    #312110 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    113 pts
    @jvalley4735

    Are you able to share your files so I can see how the action is placed and setup?  If your not comfortable attaching them onto the thread you can send them via email to jennifer.valley@trivantis.com.  I’ll only share you course files with our support or development team if I need to do some troubleshooting with them. Otherwise any one who comes across this feed may be able to help out.

    #312111 Score: 0
    Profile photo of Raphy Abano
    Raphy Abano
    Member
    beginner
    intermediate
    contributor
    @rabano9900

    Hi again, Jennifer,

    I don’t mind sharing the files, it’s a sample one that I will use as reference for future courses that I build at work.

    Please see the attachment in this message.

     

    Thanks in advance!

    #312141 Score: 0
    Profile photo of John Blackmon
    John Blackmon
    Member
    beginner
    intermediate
    contributor
    friend finder
    advanced
    junior moderator
    wise owl
    LUC16
    LUC16 Attendee
    verified member
    28 pts
    @johnb

    Have you tried setting a score? A test would set that automatically for you, but put in a score (set the AICC_Score variable) and either a completed, passed, or failed status for AICC_Lesson_Status. That should do it.

    #312150 Score: 0
    Profile photo of Raphy Abano
    Raphy Abano
    Member
    beginner
    intermediate
    contributor
    @rabano9900

    Hey John, I tried that and initially it wasn’t working.

    However, I looked at your response and the details from the xAPI statement, and didn’t know that the value for AICC_Lesson_Status is case sensitive! I had it as “Passed” or “Completed”.

    I republished it on SCORM Cloud without the first letter capitalized and it works. Thanks for the help!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.