Explore the community Forums Lectora Lectora Questions & Answers Changing When A Publish String Message Deploys

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #398760 Score: 0
    Profile photo of awilcox_
    awilcox_
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @awilcox_

    When a user clicks the “Submit” button without selecting an answer choice, the “Incorrect” pop-up appears. Is there a way to have the Publish String message “You must answer all of the questions to continue.” to pop-up at that time instead (only if a selection was not made)?

    #398768 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    228 pts
    @timk

    This Publish Strings message is meant for Tests, not so much for other questions. But you can change your Submit action to accomplish it:

    On: Click
    Action: Display message
    Message: You must answer …

    Condition:

    Only if “Question_0001” is empty

    Else:

    Action: Process question
    Target: Question 1

    Replace “Question_0001” with the appropriate question variable and “Question 1” with your questions name.

     

    #398770 Score: 0
    Profile photo of awilcox_
    awilcox_
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @awilcox_

    Thanks Tim, that’s what I was looking for. My question was a little short of information because I had just composed a much longer version that had a lot more detail in it, but I had forgotten to put the “Subject” line in and when I clicked the “Submit” button, instead of telling me to fill in the subject line, the whole thing just disappeared! So I went with the Reader’s Digest version the second time. So having said that, the question I had was regarding the String that is activated in a Test (Quiz). I have noticed that when I click on the “Submit” button in a test question without selecting an answer, it returns “Incorrect”. If I do that the specified number of times for the question, the correct answer pop-up appears, and then when that is dismissed the “You must answer all of the questions to continue.” pop-up appears from the Publish Strings. I was thinking I could change when that occurred, but it looks like your solution will work just as well. Thanks again for the help.

    #398909 Score: 0
    Profile photo of awilcox_
    awilcox_
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @awilcox_

    Hmmm, that is working, but I get two instances of the message each time. Any idea what I’m doing wrong?

    • This reply was modified 1 week, 4 days ago by Profile photo of awilcox_ awilcox_ .
    #398917 Score: 0
    Profile photo of awilcox_
    awilcox_
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @awilcox_

    Any ideas as to why I can’t delete this reply or remove attachments in a previous reply I made?

    • This reply was modified 1 week, 4 days ago by Profile photo of awilcox_ awilcox_ .
    • This reply was modified 1 week, 4 days ago by Profile photo of awilcox_ awilcox_ .
    #398967 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    40 pts
    @JasonADal

    What’s the conditional on the action to run that group? I have a similar setup, where a question MUST be answered. I create an action group called “Process question”. On the “Check Answer” button, I have “Run Process question group IF Question_0001 is NOT empty ELSE Display Message” (Mine is the opposite of Tim’s because I don’t want the action group to run if they haven’t answered the question).

    In the process question group, I add:

    • Process Question
    • Display Message “Correct” IF question is correct ELSE display message “Incorrect”.

    In terms of duplicate messaging, do you have Enable Feedback set up? If so, then when you process the question, you’ll get both the actions on the Feedback tab AND the actions you have set up. If you can post a sample, I’m happy to look at it.

     

    #399054 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    228 pts
    @timk

    Seems like the longer version of the question would have been better 😉

    I don’t know about your skills with Lectora so I’ll start at the beginning:

    There are two ways to display feedback for a question, either by using the Feedback settings of the question or by using actions. The screenshot indicates you’re using actions, so you should disable the Feedback settings of the question. If you don’t use the Feedback tab you won’t have to process the question.

    An empty question is not correct, i.e. it’s incorrect. If you run the actions one after the other it will first display the “Empty question” message, because it’s empty and then display the “Incorrect” message, because “Empty” is an incorrect answer. This can easily be solved with Jason’s advice.

    You can edit posts to this forum for the next 5 minutes or until the next reply has been posted.

    #399297 Score: 0
    Profile photo of awilcox_
    awilcox_
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @awilcox_

    Thanks for the feedback Tim and Jason. I used Lectora a couple of years ago to create quizzes, but I was given a template to use and never learned the processes of creating Action Groups, etc. Now the person who created the templates is gone and I have been tasked with fixing some of the problems that have been noticed, such as this one, where the quiz taker is told the answer is incorrect and loses one of their chances if they accidentally don’t select an answer. So basically I am a newbie, trying to figure out the logic and nomenclature of Lectora. Luckily I have the finished product that I can often backward engineer to see how it works, but sometimes I run into things like this where I feel like I am just running around in the dark. I’m pretty sure the feedback settings are on, but I can’t find where to activate/deactivate them.

    #399309 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    40 pts
    @JasonADal

    If you select the Question in the Title Manager, then Properties in the ribbon, you’ll see an Enable Feedback option. Or, you can use the Edit Question to see the Feedback Tab. The nice thing in there is that you can change what actions occur when the question is processed. By default, the action is Display Message, but you can choose just about any action type from the drop downs.

    #399312 Score: 0
    Profile photo of awilcox_
    awilcox_
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @awilcox_

    Ahh, yes, there it is. The “Feedback Enabled” box is unchecked, so I was wrong… feedback is not enabled.

    #399333 Score: 0
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    profile
    185 pts
    @Klaatu

    Post a sample

    #399473 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    228 pts
    @timk

    Alright, here is a sample.

    Also check the settings of your test. On the “Behavior” tab is a setting “User must answer each question”. This setting triggers the Publish String message via the “Go To” action in your action group if the question is empty.

    Attachments:
    1. QuestionFB.zip
    #399477 Score: 0
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    profile
    185 pts
    @Klaatu

    I meant awilcox_. Instead of shooting in the dark, a sample would help us see what he’s got going on.

    #400306 Score: 0
    Profile photo of awilcox_
    awilcox_
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @awilcox_

    Sorry about being dark for so long, I got pulled into another project.

    Here’s a sample. It seems to work, except the message about choosing an answer comes up twice in a row and has to be dismissed twice. I can’t figure out how to fix that.

    Thanks again for the help so far.

    Alan

    #400320 Score: 1
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    90 pts
    @mnotermans5114

    If you check your file thoroughly it just does exactly what you want…thus displaying the message twice 😉

    On your checkanswer button there are 2 actions… 1 calling an action group and 1 calling a message window showing the specific message. If you delete 1 of the 2 actions you will notice it only shows the message once.. so apparently somewhere in the action group ‘Answer’ you have a second call to the message window… If you check the actions in the ‘Answer’ group one by one, you quickly notice that the first action in that group… ModVar has an if statement with a showMessage on it. Apparently that variable is false, so it shows the message window there for the 2nd time.

    So either get rid of the first action…or get rid of the second one.
    Hope thats clear enough…

    Regards,
    Math

     

     

    This post has received 1 vote up.
Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.