Explore the community Forums Lectora Lectora Questions & Answers Completion status on LMS

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #371518 Score: 0
    Profile photo of Pawel Kulpinski
    Pawel Kulpinski
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    2 pts
    @pkulpinski3055

    Hi, I have a trouble with setting a “completed” status of my test on LMS. To be specific: it’s not only a test, it also has a chapter before and after the test. I set LMS to set the status to completed when test score is 75% or higher, but even then the status on LMS is still “in progres”. Maybe it’s because after the test there is still one chapter in the title, I tried to set the last page to set the variable AICC_Lesson_Status to “completed”, but this variable is not available in the title I’m working on (I have no clue why…)! Maybe you know some other way to do it? Thank you in advance.

    #371523 Score: 1
    Profile photo of Lazaro Perez
    Lazaro Perez
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    contributor
    profile
    Group Member
    picture perfect
    advanced
    28 pts
    @sirwise23

    Hi there.  If you don’t see that variable maybe you don’t have the course set up as SCORM?

     

     

    This post has received 1 vote up.
    #371526 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    picture perfect
    54 pts
    @JasonADal

    Using the KISS (keep it simple, silly)), is it an assignable unit (AU on the Home ribbon). Where do you have the AICC_Lesson_Status action set? If it’s on a button that goes to a new page or on the close course button, and sometimes the next/exit happens before the set status is set, even if the set status is the first action. I add the set status as an onPageShow with the hopes it will still set it even if the user closes the course using the X on the window.

    I have a similar intermittent problem with my LMS, Pathlore, where sometimes the test score will be recorded, but the completion status is not. The response from my administrator says that it’s typically related to how long the user takes between the time the values are set and closing the course. Thankfully, it’s been intermittent for me and users can go back in, resume and close and the information transfers.

    #371648 Score: 1
    Profile photo of Pawel Kulpinski
    Pawel Kulpinski
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    2 pts
    @pkulpinski3055

    Obviously, as usually, the simplest answer is the best answer. I was so sure, that the title is defaultly set to “SCORM”, that I didn’t even check. Thank you very much! I’ll see if it works now.

    This post has received 1 vote up.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.