Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #376364 Score: 0
    Profile photo of Indra Van Caesbroeck
    Indra Van Caesbroeck
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    1 pt
    @ivancaesbroeck1298

    Hi all,

    I’ve read through a number of different sites and help topics, but nothing seems to work (this time around).

    I am trying to use custom fonts again, but Lectora Online isn’t displaying them at all.

    I have attached an image of:

    1. The .css I use and have used before for the INGME-font (I have added the corresponding font-files in the ‘Additional files’)
    2. How the font is displayed in the drop down
    3. How the font shows up (and is supposed to look like) in ‘Page Preview’ mode

     

    The INGME font works. The Exo-font doesn’t (as you can see, it doesn’t show up at all). And I have no clue why.

    Also: the INGME-font has about 5 more variations that also refuse to show up in the font-dropdown.

    Any help is much appreciated!

    (the fonts have first been installed on my computer, all variations, and Lectora Online has been relaunched)

    #376497 Score: 1
    Profile photo of Robert Aung-Naing
    Robert Aung-Naing
    Member
    beginner
    intermediate
    friend finder
    profile
    wise owl
    contributor
    20 pts
    @raungnaing

    Hi Indra,

    The fonts defined in font-face sections (image 1) do not seem to match up with the font listing drop down (image 2). The text for font-family (in font-face) should appear in the drop down in the UI. So in this case (given image 1) I would expect to see “INGME”, “INGMEBOLD” and “Exo 2” in the drop down list. If you can provide a sample title, I can take a look.

    You no longer have to install the fonts in the computer OS. They are all self-contained in the title’s HTML Extension object.

    For the variations of fonts, you will have to define each variation as a font-face.

    Regards,

    Robert.

    This post has received 1 vote up.
    #376540 Score: 0
    Profile photo of Indra Van Caesbroeck
    Indra Van Caesbroeck
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    1 pt
    @ivancaesbroeck1298

    First of all, thank you very much for taking the time to reply!

    I have attached a package that includes the fonts. Regular, Bold and now also Italic. But I’m afraid, even after adjusting the names, they still won’t show up.

    I’m probably missing something obvious, but I don’t have to use this feature often, so it’s baffling me 🙂

    #376563 Score: 0
    Profile photo of Indra Van Caesbroeck
    Indra Van Caesbroeck
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    1 pt
    @ivancaesbroeck1298

    Right, I’ve got an update!

     

    Something no one ever mentions anywhere is that you need to go into your ‘Organization Settings’, scroll down all the way to ‘User fonts’ and manually add the fonts you want to see/use ;)!

    Whilst the reason you include the HTML-extension is because you want other users following your course to be able to see the font as well, even though they might not have it installed on their OS. (this was a really big ‘WELL DURRR’-moment for me… 😉 )

    So I’ve got a custom font which has the following types: regular, bold, italic. Only issue I have now, is that Lectora refuses to accept any other variation than ‘Standard/Regular’ of a custom font. Which is a huge pain in the buttocks.

    Attachments:
    #376611 Score: 0
    Profile photo of Robert Aung-Naing
    Robert Aung-Naing
    Member
    beginner
    intermediate
    friend finder
    profile
    wise owl
    contributor
    20 pts
    @raungnaing

    You will need to make a couple of changes to the HTML Extension:

    • Name: Lectora Custom Fonts
    • Type: Meta Tags

    You can also look at the online help by searching “custom fonts”.

    You don’t need to set the Org setting “User Fonts” any more; that’s the old way. Using that, like you said, depends on the fonts the user has installed on their computer. So it’s kind of hit or miss. HTML Ext. way is much better.

    One other enhancement you can make (I think addresses your last point) is that, by using the font-face text below you can have just one entry in the font drop down list, “ING Me”, and use Lectora Online’s Bold and Italic buttons in the ribbon menu.

    Notice all 3 font-family have the same name. Also, local is not used.

    <style> 
    @font-face { 
     font-family: 'ING Me';
     src: url('INGMe-Regular.ttf') format('truetype');
     font-style: normal;
     font-weight: normal;
    }
    @font-face { 
     font-family: 'ING Me';
     src: url('INGMe-Bold.ttf') format('truetype');
     font-style: normal;
     font-weight: bold;
    }
    @font-face { 
     font-family: 'ING Me';
     src: url('INGMe-Italic.ttf') format('truetype');
     font-style: italic;
     font-weight: normal;
    }
    </style>

    Hope it helps.

    Don’t forget to save, close and re-open the title to refresh the font list.

    #376625 Score: 0
    Profile photo of Indra Van Caesbroeck
    Indra Van Caesbroeck
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    1 pt
    @ivancaesbroeck1298

    Hi Robert,

    Thanks for the quick reply!

    However, I’m afraid you’re not correct with regards to the ‘Organization Settings’.

    I’ve been troubleshooting all day and tried many different options. But the ONLY way to get custom fonts to be displayed in the font drop-down menu is by adding them in the ‘Organization Settings’ first.

    I apologise if I haven’t been clear.

    My issue is that DURING the building of a course fonts aren’t displaying in Lectora Online. Which means I don’t know if a custom font fits into a text block properly unless I do a time-consuming full preview of each page and every time I make a textual adjustment.

    I hope I’m a bit clearer now. Again, sorry if I wasted your time by not being clear 🙂

     

    A list of the things I’ve tried:

    1. I have tried multiple variations of the font-family names (still INGMeBold wouldn’t appear)
    2. I removed ALL HTML-extensions from ALL courses in my entire Lectora Online library (still the fonts showed up in the drop-down)
    3. I removed the User Fonts from the Organisation Settings (no custom fonts were displayed, despite there being HTML extensions)
    4. I’ve tried renaming the ING Me Bold font with FontForge, giving it an entirely different font-family name (added this to the Org. Settings first, then HTML and then both, and still nothing)
    #376664 Score: 0
    Profile photo of Robert Aung-Naing
    Robert Aung-Naing
    Member
    beginner
    intermediate
    friend finder
    profile
    wise owl
    contributor
    20 pts
    @raungnaing

    Can you try this title? I updated the name and type of the HTML extension. The font drop down shows the 3 custom fonts.

    I don’t have User Fonts set in my org setting.

    Robert.

    #376734 Score: 1
    Profile photo of Indra Van Caesbroeck
    Indra Van Caesbroeck
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    1 pt
    @ivancaesbroeck1298

    YOU, sir, are my hero!!!

     

    The culprit? Single quotes… I was so sure that I had tried all variations in the CSS… How wrong was I? 😀

    Thanks a million. Really appreciate the time and effort you took to keep helping me out!!

    *add some more exclamation marks to stress my gratitude*

    This post has received 1 vote up.
    #376738 Score: 0
    Profile photo of Indra Van Caesbroeck
    Indra Van Caesbroeck
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    1 pt
    @ivancaesbroeck1298

    Right… never mind. I spoke too soon.

    In the package you provided, the custom fonts work perfectly. I even added a new font to it.

    However, I tried using your CSS in my other documents and it doesn’t work anymore 🙁 … I don’t get what is going on here?

    I tried the following:

    1. I created a new responsive title. Added the CSS , then the font-files, closed the document and opened it again to add text blocks. But no fonts.
    2. I created a blank title. Did the same steps. No fonts.
    3. I created a shared, blank version. No fonts.
    4. I created a blank version, added an HTML-extension where I added the font-files FIRST, before the CSS. Also nothing.

     

    Which steps did you follow exactly? I must be missing something here.

    EDIT: Sidenote – I copy/pasted (or copied it manually) in the other documents. When I copy/paste your HTML extension with all fonts inside etc. directly from your package into the others. It works… Pardon my French, but what the fuck -_- .

    #376747 Score: 0
    Profile photo of Indra Van Caesbroeck
    Indra Van Caesbroeck
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    1 pt
    @ivancaesbroeck1298

    (Strange, I thought I had posted a reply, but apparently not. Here goes again)

    So… I figured it out.

    You need to name the HTML-extension exactlyLectora Custom Fonts‘ and have its type set to ‘Meta Tags‘.

    I saw you specifically said you had changed the name and type, but I had no idea that the name of the HTML-extension would be absolutely critical for it to work.

    Maybe it’s just me, but that’s just plain ridiculous? I never saw any information on this anywhere. If it is critical for custom fonts to work, why isn’t it mentioned somewhere? 🙁

    PS (Please refer to my earlier post on you being my hero!)

    #376781 Score: 0
    Profile photo of Robert Aung-Naing
    Robert Aung-Naing
    Member
    beginner
    intermediate
    friend finder
    profile
    wise owl
    contributor
    20 pts
    @raungnaing

    Hi Indra,

    The instructions are in the help (Information Center); topic is “Enabling custom fonts”.  You can search for “custom fonts”.  May be we need to make it more obvious about the special name of the HTML Ext. and the type.

    I’m glad you got it working!

    Robert.

    #376789 Score: 0
    Profile photo of Indra Van Caesbroeck
    Indra Van Caesbroeck
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    1 pt
    @ivancaesbroeck1298

    Hiya Robert,

    That is embarassing!

    I thought I had done my research, I definitely (and obviously) didn’t. So caught up in my own frustration, I didn’t even thoroughly look at the Help.

    Thanks again ;).

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.