Explore the community Forums Lectora Lectora Questions & Answers Display message appears on next page

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #402064 Score: 0
    Profile photo of SB Chapman
    SB Chapman
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    contributor
    curious george
    Group Member
    @schapman1885

    I have a drag-and-drop interaction that is custom coded. The learner can drag an item, then click the Submit button to evaluate the answer and displays a message in the pop-up box. However, if the learner drag an item, then clicks the Next button, it evaluates the answer, displays a message in the pop-upbox, advances to the next page, and the message appears as text on the screen with an OK button. If you click the OK button, the text disappears.  How do I prevent the advance to the next page until the learner closes the box by clicking OK?

    #402067 Score: 0
    Profile photo of Stan Miller
    Stan Miller
    Member
    beginner
    intermediate
    LUC16 Attendee
    wise owl
    contributor
    curious george
    friend finder
    LUC17 Attendee
    39 pts
    @smiller7502

    The simplest way is probably to disable the Next button on page show, and then enable it when the learner clicks Submit.

    #402070 Score: 0
    Profile photo of Zachary Liquorman
    Zachary Liquorman
    Member
    beginner
    intermediate
    friend finder
    profile
    curious george
    wise owl
    contributor
    picture perfect
    8 pts
    @zliquorman1276

    When you say “custom coded”, do you mean you coded a drag-and-drop interaction via JS on an HTML object? Or something else?

    If the former, I would tie the “Next Page” action to the clicking of the “OK” button. Is the message that appears on-screen custom-coded as well?

    Depending on the specific implementation, it might even be easier to remove the Lectora-default “next page” action for that slide, and replace it with your own custom-code that navigates to the next page which you could tie directly to the “OK” button.

    #402075 Score: 0
    Profile photo of SB Chapman
    SB Chapman
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    contributor
    curious george
    Group Member
    @schapman1885

    Stan: Yes, I thought of this first. Just curious because on a quiz question, this doesn’t happen. wondering what code is invoked that prevents it from moving to the next page.

    Zachary: Yes, I bypassed the normal correct/incorrect for an action group (because the client wanted individual feedback per item). Suggestions on overriding the Next page action? The Next button is on the template… which is a level above the interaction.

    #402079 Score: 0
    Profile photo of SB Chapman
    SB Chapman
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    contributor
    curious george
    Group Member
    @schapman1885

    Also, this behavior is, of course, different in different browsers…..

    #402081 Score: 0
    Profile photo of Zachary Liquorman
    Zachary Liquorman
    Member
    beginner
    intermediate
    friend finder
    profile
    curious george
    wise owl
    contributor
    picture perfect
    8 pts
    @zliquorman1276

    You would disable the “next page” action for that specific slide by changing that slide’s inheritance settings to exclude the next button from the template. Then, you could just copy and paste the button from the template to that slide, and then any tweaks you make to it on that slide will only be to that slide since the button there is specific to it only, and not the template.

    #402165 Score: 0
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    131 pts
    @mnotermans5114

    Zachary solution is the easiest one.
    Another option is disable the nextButton onPageShow… then re-enable it when needed.
    I am not sure whether the disabled option is only in Lectora Online or also for Inspire/Publisher.
    If its not, another option to disable a button (or whatever interface element ) is adding a blocker on top of it.
    A shape or transparent png that shows on top of the clickable element and thus prevents the user from clicking..

    Even an empty textbox can work as a blocker 😉 Noticing that often in delivered projects… 😉

    #402173 Score: 0
    Profile photo of SB Chapman
    SB Chapman
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    contributor
    curious george
    Group Member
    @schapman1885

    Math: Any idea why I don’t see this behavior on a quiz page? I’m not sure why it doesn’t act the same way. (le sigh)

    #402212 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    355 pts
    @timk

    I can reproduce the error in Lectora 17.1.5.

    I think, the popup action in the group doesn’t interrupt the “Go to” at the button because these are separate action sequences, i.e. the popup action doesn’t know that there’s a “Go to” action. The second part of the error probably happens due to Seamless play. It can be solved by moving the “Go to” action from the button to the group.

     

     

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.