Explore the community Forums Lectora Lectora Questions & Answers Exit Button and Test Scores

Tagged: , ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #372236 Score: 0
    Profile photo of Traci Chickerell
    Traci Chickerell
    Member
    beginner
    intermediate
    curious george
    friend finder
    wise owl
    @tchickerell3433

    Has anyone else been having trouble with Lectora exit buttons and recording scores in their LMS? When I test my title in Lectora it works fine but when I upload to the LMS (SuccessFactors) it doesn’t function the same:

    • My exit buttons no longer work
    • My test questions aren’t processing, resulting in a score of 0% even if I answer them all correctly
    • My course is not marking as complete.

    Can anyone offer some guidance on this?

    Thanks!

    #372295 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    picture perfect
    54 pts
    @JasonADal

    Hi Traci – There are a few things that may come into play in this scenario, so this might be a good checklist to use to verify things are setup correctly.

    • Is the test part of Assignable Unit (AU)? If not, the course may not correctly report values to the LMS.
    • On the test Result option, is “Include test score in overall score” check marked?
    • Check the button called “Done” on the Last Test Page. When you first create a test, the only action by default is “Process Test”. Make sure that somewhere in the course the AICC_Score and AICC_Lesson_Status are set.
    • I recommend using an onShow action at the page level of the page AFTER the last test page. Using a button to set the variables can sometimes be problematic. I’ve found that setting them as an action on the Exit/Close Course button can be problematic, so I set them as onShow for the page.
    • When publishing to SCORM, is “The published course will report Test/Survey Question Interaction to the LMS” checked?

    Those are some of the things I use as a checklist when publishing my courses. Why the exit/close course button wouldn’t work on the LMS may be unrelated, but could also be affected by the order of actions on the button.

    #372328 Score: 0
    Profile photo of Traci Chickerell
    Traci Chickerell
    Member
    beginner
    intermediate
    curious george
    friend finder
    wise owl
    @tchickerell3433

    Thanks for the reply, Jason.

    • The test is part of an Assignable Unit
    • “Include test score in overall score” is checked
    • I have included AICC_Lesson_Score, but have never included AICC_Score before.  Do both need to be present and where would AICC_Score go?
    • “The published course will report Test/Survey Question Interaction to the LMS” is checked.

    It all seems very odd as the exit button no longer works to close out the course either.  Any other suggestions?

    #372340 Score: 1
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    picture perfect
    54 pts
    @JasonADal

    For the Exit Course button, try deleting and re-adding the action on the button to close the course – When I run into odd behavior on a button, this is what I’ll do and that fixes it. No idea why, but hey, it works.

    Both the AICC_Lesson_Status and AICC_Score should be set before closing the course. I’ve attached a quick sample that shows how/when I set those variables. Lectora records the test score as “test_name_score”, but does not set the AICC_Score on its own.

    Hopefully this helps!

    This post has received 1 vote up.
    Attachments:
    1. SampleTest.zip
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.