Explore the community Forums Lectora Lectora Questions & Answers Having issues with hyperlinks – V18.2.1

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #437313 Score: 0
    Profile photo of Neil Scott
    Neil Scott
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @nscott8678

    I’m having issues with getting hyperlinks to activate the required target. I have one text box with three different hyperlinks. Each hyperlink activates a separate action group.

    If for example I edit hyperlink 1, the changes are not committed correctly and will activate the target for hyperlink 3 instead. I go back in to edit and try again and again without success.

    There seems to be a bug with getting hyperlinks to ‘stick’ once they are entered.

    No matter how many times I try, I am unable to assign three separate actions to the three hyperlinks. I end up with two hyperlinks sharing the same action.

    Anyone else seeing this?

    #437315 Score: 1
    Profile photo of Adam Cain
    Adam Cain
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    Group Member
    curious george
    contributor
    19 pts
    @cainam

    I just tried out using 5 hyperlinks in the same text block without issue in 18.2.1.  Did you happen to try and create a new text block and start fresh just to see if that makes a difference?  Maybe you can share that page?

    If you need something quick, you can just make the text blue and underlined without adding a hyperlink, and add a transparent button over the top for each link?

    This post has received 1 vote up.
    #437382 Score: 0
    Profile photo of Neil Scott
    Neil Scott
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @nscott8678

    Yes, I was only able to sort it out by deleting the text box and starting over again.

    The process for adding hyperlinks seems quite fickle and troublesome.

    #437465 Score: 1
    Profile photo of CarlFink
    CarlFink
    Member
    beginner
    intermediate
    contributor
    LUC16 Attendee
    wise owl
    curious george
    advanced
    29 pts
    @CarlFink

    The process for adding hyperlinks seems quite fickle and troublesome.

    I never use the text hyperlinks. They are finicky (as you say) and sometimes hard to click on, because Lectora (and web browsers) treat the blank spaces between words and lines as null, which is irritating.

    I just use invisible buttons, as Adam suggested.

    This post has received 1 vote up.
    #437519 Score: 1
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    121 pts
    @mnotermans5114

    Biggest issue with invisible buttons is that when designing for responsive, you might have to move them. In fact you have to make sure they are big enough else browser differences might turnmoil it and your element is not clickable anymore. I do use them too though, but you have to be aware of the issues of it…  as mentioned before.

    This post has received 1 vote up.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.