Explore the community Forums Lectora LMS Integration IE compatibility mode and opening in a new window

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #297643 Score: 0
    Profile photo of Androo
    Androo
    Member
    @Androo

    Hi Guys, (Previously posted in wrong area)

    I have an interesting problem to solve. I’m producing content that is running in a large corporation. Compatibility mode is on as default when using the LMS(Oracle iLearning) due to it being considered an intranet site. The content produced really needs to run in the highest version of IE available. Typically I would just run with the following line in the header to make this happen. <meta http-equiv=”X-UA-Compatible” content=”IE=edge” />

    But… this line has no effect. This is due to the content being played within a frameset.

    In the past I’ve gotten around this by opening a popup window from the frameset to run the content in a window free from the frameset and communicated via JavaScript to the parent for any SCORM calls. But this was using hand coded HTML5 content, not lectora.

    Is there a way to do something similar in lectora?

    I’ve noticed there is a publish setting “Launch course in separate window from LMS” but haven’t noticed any change from when its selected or not. eg, the content is always in the frameset in my LMS and no new window is created.

    I think the presence of the frameset is causing IE to set compatibility mode in a setting lower than the supported by lectora. I’ve seen users browser displaying in IE5 mode, but typically IE7 mode. But… this isn’t always the case, some users are running in standards(IE10) mode.

    If you can make any sense of this ramble you might be able to help.

    Essentially I need a way of launching the content in a popup, so I can set the browser mode. IE7 just doesnt cut it when rendering content produced in Lectora.

    Thanks as always,

    Andrew

    #297691 Score: 0
    Profile photo of Daryl Fleary
    Daryl Fleary
    Member
    beginner
    intermediate
    advanced
    friend finder
    LUC16
    LUC16 Attendee
    contributor
    wise owl
    verified member
    17 pts
    @dfleary

    Andrew:

    We have encountered this issue before. In discussing it with the development group, the problem is that Lectora does not have control over the window opened by the LMS, so it is unable to change what the LMS has set as the compatibility mode; be that IE5 or IE7…whatever.  And as you correctly noted, a lot of the newer effects features in Lectora just don’t work in older browsers; or browsers that think/are behaving as though they are older browsers. We’ll keep searching for a workaround on our end, but the real fix is to have the server that the LMS is running on/serving pages from upgraded to a current browser.

    Daryl Fleary, Lectora/Lectora Online Product Manager

    #297717 Score: 0
    Profile photo of Androo
    Androo
    Member
    @Androo

    Thanks for the response Daryl,

    Our LMS partner seem to be coming to the party and making some changes on the LMS server to inject the meta tag onto the LMS player page via the content delivery network (CDN).

    When I hand coded(non lectora) a solution in the past I had to run a splash screen that launched a popup for the content to be displayed. That way the content is run independently from the LMS player. The splash screen just sits in the background running the the SCORM API. I communicated from the popup window to the splash screen via[window.opener]. This solved all the compatibility mode issues caused by the LMS. I’d love to see an option to do this in lectora, but reality most likely says otherwise.

    Thanks Again,

    Andrew

    #330243 Score: 0
    Profile photo of erin
    erin
    Member
    beginner
    intermediate
    friend finder
    wise owl
    curious george
    2 pts
    @erin

    Daryl,

    By this (“…the real fix is to have the server that the LMS is running on/serving pages from upgraded to a current browser.”) do you mean have the LMS (or server?) change its compatibility setting to a higher version/most recent version of IE? Or did you mean something different?

    Cheers,

    Erin

    #330438 Score: 0
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    118 pts
    @mnotermans5114

    Actually had the same issue this week with a larger client running Cornerstone On Demand. IE11 they used, but Cornerstone forced the browser to run IE7 mode, offcourse causing a lot not to work properly. In the end, it was just a setting inside Cornerstone that forced IE7 mode, changing that to IE10 and all worked properly.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.