Explore the community Forums Lectora Lectora Questions & Answers In Lectora 16, Invisible btns are not expanding in the phonePortrait view

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #316161 Score: 0
    Profile photo of Shannon Turner
    Shannon Turner
    Member
    beginner
    intermediate
    friend finder
    contributor
    wise owl
    4 pts
    @sturner7498

    Hi! I am working in Lectora 16. I created some buttons in the desktop view, then moved and resized the buttons for the phone view. Now, in the phone view, only half the button is clickable. I double-checked that the invisible button was covering the graphic fully and it is. This does not happen on all of my buttons, only buttons that are larger in the phone view. I did make the invisible button semi-opaque to ensure the inv button was covering the graphic fully (not shrinking) and it is.

    Any ideas on what may be happening or how I can get the buttons to stay the size I stretch them to on all views?

    #316193 Score: 0
    Profile photo of Sergey Snegirev
    Sergey Snegirev
    Member
    contributor
    intermediate
    advanced
    friend finder
    lab member
    junior moderator
    advocate
    LUC16
    LUC16 Attendee
    wise owl
    336 pts
    @ssneg

    Can you share the files?

    #316200 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    114 pts
    @jvalley4735

    I’m not seeing this as a known issue so sharing the files would definitely help troubleshoot the issue.  If your unable to share them publicly then I would suggest opening a support ticket using the bottom on the right of the screen  (under the recently active members list) or sending them an email at support@trivantis.com

    #316208 Score: 0
    Profile photo of CarlFink
    CarlFink
    Member
    beginner
    intermediate
    contributor
    LUC16 Attendee
    wise owl
    curious george
    advanced
    22 pts
    @CarlFink

    I have seen comparable problems that were cause by other objects being auto-resized and covering part of the active button–you might check whether something else (say, the empty part of a text object) is doing that.

    #316220 Score: 0
    Profile photo of Shannon Turner
    Shannon Turner
    Member
    beginner
    intermediate
    friend finder
    contributor
    wise owl
    4 pts
    @sturner7498

    I cannot share the actual files as they are client confidential; but I will change the text and save out a page where this is happening.

    I did check to see if there was another object overlapping the file and I did not find anything. Thanks for the suggestion.

    I will post the file shortly.

    #316236 Score: 0
    Profile photo of Shannon Turner
    Shannon Turner
    Member
    beginner
    intermediate
    friend finder
    contributor
    wise owl
    4 pts
    @sturner7498

    Here is the attached example file. I left the formatting of the text ‘as is’.

    Just a note, I am not using the innate text buttons or the innate image buttons in the program as the course will be translated into Arabic, Hebrew, and Thai. The button set-up we have has historically worked the best for us as we’ve had to make graphics of the text to get it to appear as intended.

    Thanks for your help in advance!

    #316250 Score: 1
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    309 pts
    @timk

    You are using “always on top” very much and it’s likely to cause issues like this. Is there a reason why you don’t layer the objects the “normal” way? Your button groups contain several images, text and invisible button. Some of these items are always on top, some are not, this may be confusing, esp. – like Carl mentioned – if your info texts are always on top and then partly over the buttons (that are always on top as well but still under the textfields). Parts of your buttons may be over the feedbackBox but under the textfields.

    Find attached your file. I’ve removed the “always on top” property from all objects. It’s now working in all views (Run mode). I adjusted the size of the feedbackBox items in Phone Portrait so they are not laying over the buttons.

    Tim

    This post has received 1 vote up.
    #316359 Score: 0
    Profile photo of Shannon Turner
    Shannon Turner
    Member
    beginner
    intermediate
    friend finder
    contributor
    wise owl
    4 pts
    @sturner7498

    Tim, I downloaded your revised version of my Lectora file and ran it in several browsers. It is not working on my end. The buttons work on the left side; but not on the right side in phonePortrait mode. I do appreciate your efforts.

    #316360 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    114 pts
    @jvalley4735

    Out of curiosity what operating system are you running on your computer? Just trying to deduce down the issue.

    #316381 Score: 0
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    profile
    199 pts
    @Klaatu

    I downloaded Tim’s file, published then placed it in my local server and ran it on my Galaxy Note 5. In portrait mode the two buttons on the bottom worked fine.

    • This reply was modified 3 years, 4 months ago by Profile photo of Darrel Somoza Darrel Somoza. Reason: left out that I published it
    #316457 Score: 0
    Profile photo of Sergey Snegirev
    Sergey Snegirev
    Member
    contributor
    intermediate
    advanced
    friend finder
    lab member
    junior moderator
    advocate
    LUC16
    LUC16 Attendee
    wise owl
    336 pts
    @ssneg

    I just tried Tim’s file and it works perfectly.

    #316532 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    114 pts
    @jvalley4735

    Since it seems to be working for other individuals I think you’d find a better resolution by submitting a support ticket.  They should be able to recreate the course using your computer settings and possibly find a better resolution.  You can contact @support (tagging them so they are aware of files you posted on the site) by emailing support@trivantis.com or selecting the “Submit a Support Ticket” under the recently active group.

    #316682 Score: 1
    Profile photo of Shannon Turner
    Shannon Turner
    Member
    beginner
    intermediate
    friend finder
    contributor
    wise owl
    4 pts
    @sturner7498

    Thanks everyone for your help. I am running Windows System 7. I retested both Tim’s version and my version IE 11 and the latest Chrome browser. They both work now in Chrome but not in IE 11 (not sure why it tested different this time). I will post what I find out while working with the Support team.

    Tim, you are right about the “Always on Top” feature creating havoc. The interaction is something we converted from Lectora 6, then Lectora 11, and are now converting to Lectora 16. A number of elements where changed along the way to always be on top because either we were having issues with the buttons not displaying as expected or our client was.

    This post has received 1 vote up.
    #317866 Score: 1
    Profile photo of Shannon Turner
    Shannon Turner
    Member
    beginner
    intermediate
    friend finder
    contributor
    wise owl
    4 pts
    @sturner7498

    I discovered what was happening here. When the invisible button in desktop view is smaller than in the other views (ex. 300×70 in desktop view and 444×80 in PhonePortrait view), the inv button is not clickable for the entire length of the button. This is an issue for ie 11.  The button works fine in the latest Chrome and Firefox browsers as well as those already mentioned in this feed.  I have not tested it yet in other versions of ie.

    To fix this, we are redesigning the desktop screen to include bigger buttons.

    This post has received 1 vote up.
Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.