Explore the community Forums Lectora Tips and tricks Internet Explorer Full Page Refresh Results in Page Flicker

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #280706 Score: 0
    Profile photo of BozoExplosion
    BozoExplosion
    Member
    @BozoExplosion

    Here is the Problem:
    A Lectora course published and viewed in Internet Explorer results in an annoying flicker whenever the user advances to the next page of the course.

    Clicking the Next button (Button Properties: On Click Tab – Action: Go To – Target: Next Page) causes IE to completely refresh the page, including re-rendering all text and graphics that are common to both pages. So the Course Title, Chapter Title, top bar graphic, etc. are all erased and then re-drawn. Of course the result is that these items always “flicker” to the user’s eye. It’s Infuriating! I’m testing this in IE 6 – 9.

    Firefox (oldest version tested – 3.6.24) does NOT give this effect. In FF all page transitions are as smooooooth as buttah. But not all of my audience uses Firefox.

    Here is What I Think I’m Going to Do About It:
    I add an External HTML Object at the title level and set it to Type: Meta Tags.
    Then I paste in the following Conditional Comment (visible only to IE):

    < *--[if IE]>
    < ~meta http-equiv="Page-Enter" content="blendTrans(Duration=0)">
    < ~meta http-equiv="Page-Exit" content="blendTrans(Duration=0)">
    < *[endif]-->

    (Note: the syntax in those conditional comments is intentionally errant in the post because, when the syntax is actually correct, the text of the code does not display in the forum! Ok, so to get the real syntax do this:
    1. Substitute an exclamation point character (!) for the two asterisks above.
    2. There should be no tilde characters (~), so remove those and you have the actual syntax I’m using.)

    There is another option as well that uses transition opacity, but the one above seems to work (a little) better.

    But This Doesn’t Do a Good Job:

    After the first 5 or 6 page refreshes the flicker seems to calm down quite a bit, but it takes 5 or 6 pages and never goes away altogether.

    So does anybody have a better, more effective way to do this?

    #302154 Score: 0
    Profile photo of Sachin Kondekar
    Sachin Kondekar
    Member
    beginner
    intermediate
    @skondekar4261

    I’m also facing same problem so i’m unable to use lectora due to this issue. can any one resolved same?

    #302204 Score: 0
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    profile
    199 pts
    @Klaatu

    There are two attributes for the <script> tag to control how the page is parsed when it gets to a script. If neither are used then when the parser gets to the link to a script, it pauses parsing the HTML, gets the script and executes it before returning to complete the parsing of the HTML. This is what I suspect may be causing the screen flicker.

    Async will continue parsing the HTML while the script downloads. When it has finished downloading the parser will pause parsing the HTML until the script is run.

    With defer added, all the HTML will be parsed then scripts will be executed in the order of the script links on the document.

    This website
    <h1>Growing with the Web</h1>
    Explains the good, the bad and the ugly of it. I think IE9 and under has problems with defer causing scripts to run out of order.

    Try to add async just before the greater-than sign of the first script tag. Make sure you do this for ALL the externally linked JavaScript. Let us know if that makes a difference.

    DRS

     

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.