Explore the community Forums Lectora LMS Integration Lectora courses crash on the user side

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #393459 Score: 0
    Profile photo of R C
    R C
    Member
    beginner
    intermediate
    picture perfect
    curious george
    profile
    wise owl
    @rcrten5905

    As a relatively new Lecora user with little knowledge of web programming, I have a question about the following Lectora/ILIAS problem:

    I created a Lectora course that worked fine on my tests. After the export as SCROM 1.2 and integration into the ILIAS LMS some users (not all) report crashes of the course.

    Sure, this can also be due to the configuration on the user side, but while testing the online (ILIAS) version I always get error messages in the debugging console during my tests in different browsers.

    The following errors are thrown on each page (firefox debug):
    TypeError: getComputedStyle(…) is null[Weitere Informationen]  mediaelement-and-player.js:462:5
    mejs.MediaFeatures.init/t.supportsPointerEvents< https://lernwelt.fraunhofer.de/data/Test8/lm_data/lm_108818/mediaelement-and-player.js:462:5
    mejs.MediaFeatures.init https://lernwelt.fraunhofer.de/data/Test8/lm_data/lm_108818/mediaelement-and-player.js:449:30
    <anonym> https://lernwelt.fraunhofer.de/data/Test8/lm_data/lm_108818/mediaelement-and-player.js:579:1

    SyntaxError: expected expression, got ‘,'[Weitere Informationen]  trivantis.js:3919:92

    The debugging console from Chrome throws these errors:
    Uncaught SyntaxError: Unexpected token ,
    setTimeout (async)
    PreloadResources @ trivantis.js:3919
    init12 @ page88563.html:175
    init @ page88563.html:168
    load (async)
    (anonymous) @ page88563.html:143

    Source-View
    https://lernwelt.fraunhofer.de/ilias.php?baseClass=ilSAHSPresentationGUI&ref_id=8806
    preload( ‘images/progress31438_bar.png’,’images/progress31438.png’,’images/grauflaeche.png’,,’images/box_check.png’,’images/box_aktuell.png’,’images/box.png’,,’images/box_check.png’,’images/box_aktuell.png’,’images/box.png’,,’images/box_check.png’,’images/box_aktuell.png’,’images/box.png’,,’images/box_check.png’,’images/box_aktuell.png’,’images/box.png’,,’images/box_check.png’,’images/box_aktuell.png’,’images/box.png’,,’images/box_check.png’,’images/box_aktuell.png’,’images/box.png’,,’images/box_check.png’,’images/box_aktuell.png’,’images/box.png’,,’images/box_check.png’,’images/box_aktuell.png’,’images/box.png’,’images/logo.png’,’media/modul_1-3-5.mp3′,’media/modul_1-4-1.mp3′,’media/modul_1-4-2.mp3′,’media/modul_1-4-3.mp3′,’media/modul_1-4-4.mp3′,’media/modul_1-5-1.mp3′,’images/fcpa.png’,’images/bribery_act.png’,’images/web.png’,’images/web.png’ )

    A TypeError is not displayed by the Chrome debugger

    Can these error messages be the cause of the crashes or are they normal and can they be ignored?

    I am using Lectora Publisher Version 17.1.3(11275)

    With thanks in advance and kind regards
    R.Cürten

    #393914 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    355 pts
    @timk

    There are more errors than I’d usually expect.

    Is there a pattern when the course crashes?

    Do you have custom scripts in your course?

    My last view on Ilias is quite a while ago, but many LMS close the window if you use a browser function to reload a page, e.g. [F5].

    #394357 Score: 0
    Profile photo of R C
    R C
    Member
    beginner
    intermediate
    picture perfect
    curious george
    profile
    wise owl
    @rcrten5905

    Thank you for your response.

    The only recognizable pattern is the use of Internet Explorer and we don’t use any custom scripts in the course.

    I hope that these hints will help in solving the problem.

    #394378 Score: 0
    Profile photo of CarlFink
    CarlFink
    Member
    beginner
    intermediate
    contributor
    LUC16 Attendee
    wise owl
    curious george
    advanced
    friend finder
    47 pts
    @CarlFink

    Wild guess: publish with your language set to English (not German) and see if you get the errors. I’m just wondering if maybe the German translation is (for instance) introducing an unescaped space or non-ASCII character that the JavaScript interpreter can’t understand. If that is the case, it’s a bug that Trivantis can and should fix, and should be straightforward.

    #394401 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    355 pts
    @timk

    Most of my courses are German and I never had similar issues. Wouldn’t a real javascript error make the course crash for all users in all browsers?

    I’d be glad to take a look, are you able to share the file?

    #394586 Score: 0
    Profile photo of R C
    R C
    Member
    beginner
    intermediate
    picture perfect
    curious george
    profile
    wise owl
    @rcrten5905

    In what format should I share the course?

    The Lectora-course as zip or the SCROM Version?

    And I still have to clarify whether I have the permission to share the file.

    • This reply was modified 2 years, 6 months ago by Profile photo of R C R C.
    Attachments:
    1. debug.zip
    #394591 Score: 0
    Profile photo of R C
    R C
    Member
    beginner
    intermediate
    picture perfect
    curious george
    profile
    wise owl
    @rcrten5905

    The debug.zip uplaod was just for testing, so please ignore this file or tell me please how i can delete this attachment.

    #394616 Score: 0
    Profile photo of R C
    R C
    Member
    beginner
    intermediate
    picture perfect
    curious george
    profile
    wise owl
    @rcrten5905

    I did another test with an html version via XAMPP and both errors show up. So it is not an ILIAS specific problem.

    On the screenshot you can also see where the SyntaxError (double comma) appears in the preload.

    #394903 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    117 pts
    @jvalley4735

    Is this still an outstanding issue?

    #394957 Score: 0
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    profile
    209 pts
    @Klaatu

    RC, please check to see and let us know what mode Internet Explorer is running in while viewing the content that crashes. Hit F12 and then select Emulation.

    https://ibb.co/eTG79H

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.