Explore the community Forums Lectora LMS Integration Lectora not functioning as expected in Cornerstone

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #407528 Score: 0
    Profile photo of Ari Bloomberg
    Ari Bloomberg
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @abloomberg5365

    Hi –
    I have built a Learning module which restricts the learner progressing on certain pages unless they complete the tasks (see all the content).
    This works perfectly in the preview but when uploaded to Cornerstone the restriction is not working.
    It looks to me as if the group action is simply not being run.
    I have tried having the action group at the title level and on the page to no avail and even added a text on the page to show the state in order to see what was going on and the state of the page is simply not showing correctly.
    I am using the in progress state for the pages I want to restrict forwarding for.

    I can provide more details and an example  but wondered if anyone else has had similar issues.

    #407535 Score: 0
    Profile photo of Ari Bloomberg
    Ari Bloomberg
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @abloomberg5365

    This is an example, all be it a little more simplistic, of what I am doing.

    #407545 Score: 0
    Profile photo of Adam Cain
    Adam Cain
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    Group Member
    curious george
    contributor
    3 pts
    @cainam

    Hard to tell exactly what your setup is without seeing the module.

    I’ll just mention another option I use which works pretty well, and can be created pretty easily per page:

    1. Create a transparent button over your ‘next page’ button, which displays a message something like ‘complete all activities on the page before continuing.
    2. when the user interacts with your button or activity on the page, add an action to that button to hide the transparent button that is on top of the ‘next page’ button.
    3. This is the simplest scenario with one item to interact with on the page.  If more items on the page, you can add an action per button/activity to modify a variable.  Another action after that one will hide the transparent button you have over your next button, if that variable condition is met.

    hope this helps!

    #407547 Score: 0
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    106 pts
    @mnotermans5114

    Cornerstone has the irritant habit of setting IE-compatibility to a often too low value. Somewhere you can find a setting to make sure IE-compatibility is set to version 11 or whatever. Im sure when you change that, all will work as planned.

    #407549 Score: 0
    Profile photo of Ari Bloomberg
    Ari Bloomberg
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @abloomberg5365

    Thanks  yes that is helpful.
    I was trying to have the button disabled and use that proper functionality and the setting state of the page etc.

    I am using a variable to collect the details of which items have been seen and hence decide to show enable the next button (I also have it set a variable I was using to block keyboard arrows forwarding for accessibility)..

    I have added a simple example  but will draw up a more accurate one to post here and which will be helpful for me to test with also.

    It is just odd that it works in Lectora but not in cornerstone …  Thank you

    #407551 Score: 0
    Profile photo of Ari Bloomberg
    Ari Bloomberg
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @abloomberg5365

    I had played with the IE-compatibility but to no avail yet —  I will try it again   thank you for the suggestion.

    #407589 Score: 0
    Profile photo of Ari Bloomberg
    Ari Bloomberg
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @abloomberg5365

    Just to report IE-compatibility setting has had no impact.

    #407608 Score: 0
    Profile photo of Ari Bloomberg
    Ari Bloomberg
    Member
    beginner
    intermediate
    curious george
    wise owl
    contributor
    @abloomberg5365

    Resolved …  I think  (after MUCH finagling).

    I deselected the option in Lectora for “publish for seamless play” when exporting to SCORM.

    Everything seems to work fine as soon as I do that.
    I am not exactly sure I understand what that setting is supposed to do or how it is supposed to help. Sounds like it is supposed to help the loading from one page to the next be more “seamless” (please correct me if I am wrong on that). If this is so then perhaps it is pre-loading the next page in some way and is thus messing up the page completion state which I am using to track page completion (seamed like a sensible use for it to me 😉 ). I have no clue, either way I saw no benefit to other pages when using it and disabling it fixed this rather important issue for me.

    Thanks for the comments and advice. Should this perhaps be reported as a potential bug with that functionality?
    I hope this is of help to others with similar issues.

     

    #408278 Score: 0
    Profile photo of CarlFink
    CarlFink
    Member
    beginner
    intermediate
    contributor
    LUC16 Attendee
    wise owl
    curious george
    advanced
    13 pts
    @CarlFink

    Seamless Play replaces the older system of having a separate HTML file for each Lectora page object, with an AJAX-based system in which the contents of the page are replaced. In principle this reduces bandwidth needed and thus delays. In practice it is buggy and nobody I know of actually uses it yet.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.