Explore the community Forums Lectora Lectora Questions & Answers Missing type information in xAPI statements

Tagged: 

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #377858 Score: 0
    Profile photo of Dylan Kauling
    Dylan Kauling
    Member
    beginner
    intermediate
    friend finder
    picture perfect
    curious george
    @dkauling9798

    Hello everyone!

    I’m currently checking out the trial of Lectora Publisher 17, but I am having a lot of issues related to tincan and xAPI. The biggest issue right now is that the statements being sent do not include the activity type in the definition of the object.  For example, a statement for a user attempting the course has an object like this:

    “object”: {
    “definition”: {
    “name”: {
    “en-US”: “Module 4”
    },
    “description”: {
    “en-US”: “Course Description Goes Here”
    }
    },
    “id”: “module4”
    }

    Whereas the software we are trying to replace would have an object like this:

    “object”: {
    “id”: “module4”,
    “objectType”: “Activity”,
    “definition”: {
    “type”: “http://adlnet.gov/expapi/activities/course”,
    “name”: {
    “und”: “Module 4”
    },
    “description”: {
    “und”: “Course Description Goes Here”
    }
    }
    }

    As can be seen, the definition type is set to course in the other software, which is an important distinction to us for telling whether or not a statement was related to a course, module, interaction, or objective.
    Normally we could work around this by comparing the object Ids to their definitions in the published tincan.xml file, but this is lacking definitions for any activities besides the course itself. It should also contain the IDs and types of every slide/page, quiz/survey/objective, and question/button/interaction in the content.
    Below is an example tincan.xml file from my test module which only contains the course definition, even when the content had questions/surveys/tests. Maybe something will stand out as incorrect.

    <?xml version=”1.0″ encoding=”UTF-8″?>
    <!–GENERATED BY: Lectora Publisher v.17.0.6(11164) (http://www.trivantis.com) –>

    <tincan xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”
    xmlns:xsd=”http://www.w3.org/2001/XMLSchema”
    xmlns=”http://projecttincan.com/tincan.xsd”>
    <activities>
    <activity id=”http://www.uniqueurl.com/module-4″ type=”http://adlnet.gov/expapi/activities/course”>
    <name lang=”und”>Module 4</name>
    <description lang=”und”>Course Description Goes Here</description>
    <launch lang=”und”>a001index.html</launch>
    </activity>
    </activities>
    </tincan>
    I’ve tried setting the title options to SCORM or normal, tried all manner of publishing options for xAPI, and rearranging the content heirarchy.
    Is all of this information simply not implemented in your xAPI support? Or am I maybe missing something in the Trial version? This is critical for our adoption of the software, so I’m hoping I’m just missing something!
    I’ve attached a redacted version of the content if that helps too.

    Thanks,

    Dylan

    • This topic was modified 2 years ago by Profile photo of Dylan Kauling Dylan Kauling. Reason: Missing attachment and poor formatting
    • This topic was modified 2 years ago by Profile photo of Dylan Kauling Dylan Kauling.
    • This topic was modified 2 years ago by Profile photo of Dylan Kauling Dylan Kauling.
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.