Explore the community Forums Lectora Lectora Questions & Answers Multiple Response Questions Not Working?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #322586 Score: 0
    Profile photo of Vicki
    Vicki
    Member
    beginner
    intermediate
    friend finder
    curious george
    wise owl
    contributor
    picture perfect
    4 pts
    @Vicki

    I updated to 16.2 last week.

    I have an interaction that uses a combination of multiple choice and multiple response questions. When I run the interaction in Preview Mode or Preview in Browser (IE & Firefox), the multiple choice questions are processed correctly, but the multiple response are not. The multiple response are always processed as incorrect.

    Since the multiple choice questions are working correctly and all the questions have the same actions, this leads me to believe that the issue is with the multiple response questions.

    Is anyone else experiencing this or something similar?

    Thanks!

    #322645 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    113 pts
    @jvalley4735

    There was a high volume of issues associated with 16.2. If possible I would try downloading 16.2.1 and seeing the issue still happens.  You can find the download files here http://trivantis.com/service-pack-downloads/ or select the auto update options from within Lectora.  Since it was just released today it might not show up right away.

    #322648 Score: 0
    Profile photo of Vicki
    Vicki
    Member
    beginner
    intermediate
    friend finder
    curious george
    wise owl
    contributor
    picture perfect
    4 pts
    @Vicki

    I had downloaded and installed 16.2.1 first thing this morning. It did not fix the issue.

    I will probably reinsert the question from scratch to see if it is a version issue.

    Thanks!

    #322821 Score: 0
    Profile photo of Vicki
    Vicki
    Member
    beginner
    intermediate
    friend finder
    curious george
    wise owl
    contributor
    picture perfect
    4 pts
    @Vicki

    Here is an update. After working with one of your AWESOME support folks (Thanks again, Fred!)…the multiple response questions have a couple of bugs.

    First bug…if you have actions linked to a multiple response question in an external group, they don’t recognize the question. In my interaction, once the answer button is selected, an action group of feedback actions is fired. Within those feedback actions are actions that require IF the question is correct/incorrect. The feedback is in another group. The test question was not being recognized as correct so the incorrect actions would be run.

    The fix was to use the built-in question feedback to have my correct/incorrect feedback show and remove the actions from the feedback group. However, now my counter of questions correct is not working since the question is not recognized as correct.

    Second bug that we found during problem solving of the first…if you have two answer choices that are the same, if you select one of the answers, Lectora automatically selects both. For example, as we set up test questions to try different orders of actions, we put in a simple multiple response question with the answers Yes, Yes, No (so you can easily know which answers were correct). If you selected one of the Yes’s, both would become checkmarked.

    Anyhow, attached is a screenshot of one of the questions with the solution on recognizing correct/incorrect already applied. Now to tackle the counter. WooHoo!

    #322823 Score: 1
    Profile photo of Vicki
    Vicki
    Member
    beginner
    intermediate
    friend finder
    curious george
    wise owl
    contributor
    picture perfect
    4 pts
    @Vicki

    As an update to my update (and I am proud of myself for figuring it out)…

    The counter is now working. I put in actions to change the count and update the text box when the Correct feedback shows.

    The inability to use random question selection based on whether the question was previously answered correctly or not was addressed by adding another action to the Correct Feedback box that assigned the question a variable. If the question has that variable it won’t show again.

    Patting self on back. Have a great day all!

    This post has received 1 vote up.
    #323498 Score: 1
    Profile photo of rwalters
    rwalters
    Member
    contributor
    beginner
    intermediate
    advanced
    curious george
    wise owl
    7 pts
    @rwalters

    What I had to do for multiple response questions is use the question variable, the “equal to” or “not equal to” relationship and then input the exact answer to the question (which should look like “answer one,answer two” with no spaces before or after the comma and of course no quotes).

    This post has received 1 vote up.
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.