Explore the community Forums Lectora Inspire Tools Questions & Answers Next Button doesn't show on Google Chrome

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #415957 Score: 0
    Profile photo of Therese Michael
    Therese Michael
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    contributor
    @tmichael9734

    I’m moving this conversation to here in hopes to benefit from your experience.  I posted in Tips and Tricks before that I’ve an issue with Next button that it doesn’t show when I test my course on Google Chrome.

    I just moved my training to Lectora 18.0. However, I tested the .html generated by 17 and had the same issue: the Next button doesn’t appear when using Google Chrome.  The Next button is actually an arrow image that I used in Image Button to create the button.  There are also assigned shortcuts to Next/Previous buttons: OnRightArrowGotoNextPage and OnLeftArrowGotoPreviousPage.

    I publish my training for SCORM, but usually test the button using the index.html file. It works fine with Edge and IE but not in Chrome.  I’m also using the Accessibility feature if that helps.

    I’m not sure if my workplace rules would allow me to upload the file but I’ll appreciate any helping tip.

    #415962 Score: 0
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    profile
    192 pts
    @Klaatu

    We really need to see a sample. Can you make a sample (that doesn’t work for you) with just two pages without any proprietary info to share?

    #415965 Score: 0
    Profile photo of Therese Michael
    Therese Michael
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    contributor
    @tmichael9734

    Thank you Darrel,

    Here are two snapshots, the 1st one is the first page and it doesn’t show the right arrow for Next.  The 2nd picture is the 2nd page and it doesn’t show the Next arrow as well. Also the Chrome hid the page number at the right bottom. It should be 2/5

    Thank you again,

    #415969 Score: 0
    Profile photo of Adam Cain
    Adam Cain
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    Group Member
    curious george
    contributor
    10 pts
    @cainam

    When you preview the page in browser (without publishing first), does the button show up?  (if it shows up there, but not when you publish, then perhaps you could play with the publish settings.

    I’ve had a course from a vendor that didn’t work inside of the company browser settings because we didn’t have the particular assets (shapes) available and would need to adjust our settings to make it work (in that case the buttons were showing an ‘x’ like an unloadable image should be there).  Instead, we had the vendor change the buttons…but since your left button works, and just not your right, then that doesn’t seem like a likely cause, but worth investigating by trying some other type of object as your button to help you diagnose the problem.

    Have you tried adjusting your Chrome settings at all, or maybe try on another device running Chrome to see if you experience the same issue?  Seems like the most likely culprit this is working on other browsers, but hard to say for sure without digging into the .awt file a bit.   Just some ideas…

    #415973 Score: 0
    Profile photo of Therese Michael
    Therese Michael
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    contributor
    @tmichael9734

    @adam Cain,

    Thank you for your response. Yes, it does work in the Preview mode on Chrome, Edge and IE.  When published it only works fine with Edge and IE; however, I need to make it work on Chrome as well.

    Do you have recommended settings for Google that I can play with?

    Thank you again,

     

    #415977 Score: 1
    Profile photo of Adam Cain
    Adam Cain
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    Group Member
    curious george
    contributor
    10 pts
    @cainam

    I would start with the HTML options tab when publishing (if it works when you preview in chrome vs after you publish).

    Do you have ‘Publish for Seamless Play’ checked?  If so, try unchecking that –

    Uncheck ‘Create ALT tags for images and buttons perhaps?

    Basically, just try some different options to better diagnose where the problems lies – maybe someone else has run into this though, and can provide the solution…

    Also – are you testing after you upload to your LMS, or outside the LMS?  just wondering if the problem persists across both.

    This post has received 1 vote up.
    #415979 Score: 0
    Profile photo of Joe Wieloch
    Joe Wieloch
    Moderator
    beginner
    intermediate
    friend finder
    contributor
    LUC16 Attendee
    verified member
    wise owl
    LUC17 Attendee
    advanced
    picture perfect
    41 pts
    @wheels

    Adam has some great tips to troubleshoot, if you can make a clean sample title that has the issue and upload a zip export of that and your publish options it will help us figure out what’s going on.

    #415981 Score: 0
    Profile photo of Therese Michael
    Therese Michael
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    contributor
    @tmichael9734

    @adam & @joe, thank you both.  I’ll work on a clean sample and upload it in an hour or so.

    Many thanks.

    #415991 Score: 0
    Profile photo of Therese Michael
    Therese Michael
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    contributor
    @tmichael9734

    I’m sorry Joe and Adam, I’ve encountered technical problems with Lectora and our server that interrupted my sample production.  I’ll attach it here as soon as it is resolved.  Thank you for your readiness to help.

    #417052 Score: 0
    Profile photo of Therese Michael
    Therese Michael
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    contributor
    @tmichael9734

    I’m back and sorry for my delay.  I’m attaching the zip file here.  If you open it with IE, the Next, Previous arrows and Page Count show.  If you preview it on Google Chrome, the three element don’t show.  Any advice please?

    Thank you,

    #417094 Score: 0
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    profile
    192 pts
    @Klaatu

    Thank you for uploading the sample. You only included the exported content so we cannot check it in preview. However, when I open the content in Chrome (Version 72.0.3626.81 (Official Build) (64-bit)) it looks and works as intended.

    #417096 Score: 0
    Profile photo of Therese Michael
    Therese Michael
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    contributor
    @tmichael9734

    Thank you Darrel for your quick response, I think it’s about my Chrome’s setting but I don’t know how to set my Chrome to display the arrows.  Any recommendations?

    #417098 Score: 0
    Profile photo of Therese Michael
    Therese Michael
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    contributor
    @tmichael9734

    Sorry I missed to put my Chrome’s version. Here it is: Version 68.0.3440.106 (Official Build) (32-bit)

    #417156 Score: 0
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    profile
    192 pts
    @Klaatu

    I would suggest two things to do. First, update chrome. To do this click on the three vertical dots in the top right corner – select Help – Select About Google Chrome. This should automatically start the check and update.

    Test to see if your output is as intended.

    If not, click the three dots again and then select Settings. From there scroll all the way down and you will see Advanced, click it. Scroll all the way down again and you should see Restore settings to their original defaults under Reset and clean up. Use this to restore your chrome settings to default.

    Let me know if these have any result.
    <div id=”chromeCleanupSubpageTrigger” class=”settings-box”></div>

    #417265 Score: 0
    Profile photo of Therese Michael
    Therese Michael
    Member
    beginner
    intermediate
    curious george
    wise owl
    friend finder
    contributor
    @tmichael9734

    Thank you Darrel.  The System Admins are the only ones who can update the browsers.  Anyway, I requested the update and I’m waiting for their approval.  I’ll keep you posted.

    Have a great weekend,

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.