Explore the community Forums Lectora Lectora Questions & Answers On a randomized test, how do you exit the title?

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #411465 Score: 0
    Profile photo of jan waginski
    jan waginski
    Member
    beginner
    intermediate
    wise owl
    curious george
    contributor
    @jwaginski

    I followed the randomized test instructions here (https://community.trivantis.com/knowledge-base/creating-randomized-tests-in-lectora-and-lectora-online/) but I’m getting an error that there’s no “exit title” action. When I add one and upload the SCORM to Moodle, it gets stuck on the last test page, i.e. it’s set to randomly choose 3/10 questions – it won’t go past the 3rd question/process the test.

    In the instructions above, there’s no exit title action. How do you exit the title correctly? And can you add a results section to a randomized test?

    #411484 Score: 0
    Profile photo of Adam Cain
    Adam Cain
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    Group Member
    curious george
    contributor
    3 pts
    @cainam

    I believe for any SCORM course, you generically just need an ‘exit’ action anywhere in the course (even if you aren’t actually going to use it)

    A couple things to check:

    1. For the test – click the RESULTS tab, and if you would like the test to be graded, and show the user the results, click those 2 options (along with passing percentage)
    2. To assign what to do after the test is completed (passed / Failed), from the test, click the BEHAVIOR tab to assign what page you want the user to go to if the pass (presumably you would create a ‘congratulations’ page or similar).  And assign what page you want to take the user if the Fail (e.g. a fail page, or back to the beginning of the test to take again).
    #411489 Score: 0
    Profile photo of jan waginski
    jan waginski
    Member
    beginner
    intermediate
    wise owl
    curious george
    contributor
    @jwaginski

    Thanks! That’s what I did and it usually works, but when it’s set to randomize, I’m having issues. I got rid of the results section and I’m still having this problem of the test not being processed. It just won’t go past the last question. (I’ve sent this to support – I’m probably missing something obvious.)

    #411491 Score: 0
    Profile photo of Adam Cain
    Adam Cain
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    Group Member
    curious george
    contributor
    3 pts
    @cainam

    Does it work when you preview, but just not when uploading to Moodle?

    #411506 Score: 0
    Profile photo of jan waginski
    jan waginski
    Member
    beginner
    intermediate
    wise owl
    curious george
    contributor
    @jwaginski

    Same issue when I preview.

    #411510 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    251 pts
    @timk

    Where do you have the “Exit title” action? It should not be inside the test chapter. Can you share the title? I’ll be glad to take a look.

    As Adam mentioned there’s no need to run the action. It’s sufficient if you add the action to a group on the first page and never run the group. Lectora needs the action because it also includes LMS commands to finish the session, but the function just has to exist.

    #411512 Score: 0
    Profile photo of jan waginski
    jan waginski
    Member
    beginner
    intermediate
    wise owl
    curious george
    contributor
    @jwaginski

    Thank you! I put “exit title” in a separate chapter and that seems to be working.

    New problem: I added test results. When the checkmark button on the test results page is set to go to the page in the last chapter with the exit title action, the publish error tells me that only “prev/next page” actions are permissible in random mode. But when I change that button on the results page to go to the next page, it selects a page from the test and does not go to the next chapter.

    (title attached)

    Attachments:
    1. CSV-Qs.zip
    #411515 Score: 0
    Profile photo of Adam Cain
    Adam Cain
    Member
    beginner
    intermediate
    profile
    picture perfect
    wise owl
    friend finder
    Group Member
    curious george
    contributor
    3 pts
    @cainam

    (If I’m understanding the issue correctly…)

    The navigation after the test results are viewed are controlled by the Test Settings (Behavior tab).  It is a bit strange the way it presents, but the action on the checkmark button will essentially retrieve the action you have assigned from the test settings (it isn’t really a ‘next page’ action, but a reference).  So just leave the action as the default, and control the action by the Test Behavior tab.

    #411529 Score: 1
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    251 pts
    @timk

    You can’t have the results page within the scope of the randomization. Otherwise Lectora regards it as a question page and if it’s randomly excluded from the test, the “Process test” action can’t work and if it’s part of the test, it won’t work neither. I attached your title with a way to handle it.

    This post has received 1 vote up.
    Attachments:
    1. Import-CSV-Qs.zip
    #411571 Score: 0
    Profile photo of jan waginski
    jan waginski
    Member
    beginner
    intermediate
    wise owl
    curious george
    contributor
    @jwaginski

    Thank you Tim!

    That makes sense with respect to how it handles results within randomization. So the solution is just to put the whole test within a test section and the results on another page within that test. Very neat!

    #411586 Score: 0
    Profile photo of jan waginski
    jan waginski
    Member
    beginner
    intermediate
    wise owl
    curious george
    contributor
    @jwaginski

    Any idea why the exit title action on the last page (the “bye” page) doesn’t close the title? In Moodle (set to open in a new window), that action seems to do nothing.

    #411589 Score: 0
    Profile photo of jan waginski
    jan waginski
    Member
    beginner
    intermediate
    wise owl
    curious george
    contributor
    @jwaginski

    Ah – I ticked “published course will be presented in a separate window than the LMS” and it is now closing properly.

    #412075 Score: 0
    Profile photo of jan waginski
    jan waginski
    Member
    beginner
    intermediate
    wise owl
    curious george
    contributor
    @jwaginski

    Hi Tim,

    Curiously, the file is not reporting results to Moodle.

    The results page shows the accurate score and correct feedback but 0% is always reported to Moodle, and the “bye” page in the title is showing “you’ve failed” when the score is 100%.

    I’ve been through the settings several times and can’t figure out how to sort this out. The most recent version of the file is attached.

    #412090 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    251 pts
    @timk

    Sorry, my fault. In earlier versions of Lectora you didn’t have to process a randomized test, but nowadays you need it. Add a Condition to the Next buttons action:

    On: Click
    Action: Go to
    Target: Next page

    Condition: If PageInChapter less than 3 (the number of randomly displayed pages)

    Else: Process Test / Survey

     

    #412181 Score: 0
    Profile photo of jan waginski
    jan waginski
    Member
    beginner
    intermediate
    wise owl
    curious george
    contributor
    @jwaginski

    Thank you, Tim. Works great!

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.