Explore the community Forums Lectora Lectora Questions & Answers Publish for Seamless Play

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #369376 Score: 0
    Profile photo of amanda hetherington
    amanda hetherington
    Member
    beginner
    intermediate
    friend finder
    curious george
    picture perfect
    wise owl
    contributor
    7 pts
    @ahetherington9113

    Hi again

    I’m using Lectora Inspire v17.0.5

    I’ve attached two zipped files. They are almost the same however one I have published with seamless play enabled and the other I have published with seamless play disabled.

    I’m hoping that someone can understand the problem I’m having and why I believe it is caused by Seamless Play.

    Perhaps there is a workaround that I don’t know about. Perhaps I’m doing something wrong..? It has worked in the past … the title was published and working before I upgraded to Lectora 17… which is why I looked at Seamless play as the possible cause.

    I have an action at the top level on my title that increments a variable by 1 when a page is viewed (but only the first time the page is viewed). When I publish with Seamless play enabled, this does not work. When I published with Seamless play disabled, it works.

    Unfortunately, I’ve tried publishing with Seamless play disabled, however this causes the Full Screen icon on my Vimeo embedded videos to disappear. So at first I thought I would be able to leave the Seamless play disabled, but of course, that is not an option.

    If anyone can assist, I would greatly appreciate it.

    Thanks so much!

    Amanda

    #369401 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    354 pts
    @timk

    I can only guess, but I believe it’s working correctly both seamless and not. It seems that the tracking status is set earlier with Seamless Play so the page is already completed before the action to increment the variable is run, i.e. is not run due to the condition.

    If you turn the logic around and count the completed pages it’ll work.

    As I wrote before, it would be easier to handle the tracking status if a page was set to “In progress” On: show (if not yet completed) and to “Completed” On: Hide.

    #369525 Score: 0
    Profile photo of amanda hetherington
    amanda hetherington
    Member
    beginner
    intermediate
    friend finder
    curious george
    picture perfect
    wise owl
    contributor
    7 pts
    @ahetherington9113

    Thanks Tim. I may have missed your previous response, sorry!

    I’ve had a look at this, but I can’t make it work for my title. I don’t want to have to create an action for each page (my title has 20 chapters, and I have a series of titles that will work the same way), which is why I have the action at the title level and referencing ‘this page’.

    Changing the condition to ‘Completed’ did not increment the variable…. not sure why, because logically I think it should work..? I just need the condition to stop a page from being counted more than once if I visit that page more than once.

    Daryl Fleary is looking at the case.. so I will wait to find out more from him.

    Thanks so much for your time on this.

    🙂

     

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.