Explore the community Forums Lectora Lectora Questions & Answers Scrolling test results

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #353985 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    picture perfect
    45 pts
    @JasonADal

    I have an issue with the test results object on a test results page where it is not allowing for scrolling, but ONLY in IE. I tested through both ReviewLink and using the browser preview within Lectora with the same result. I’m using 16.2.2 and it works fine in Firefox and Chrome.

    (I seriously want to grab IE by the neck and give it a good shaking already today.)

    #353991 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    316 pts
    @timk

    What did you do to make it scroll? Why does everything in your course has to scroll ? 😉 In one of my courses I used javascript to append the results object to a custom div and make that scroll, in IE as well.

    … and welcome to the world of Microsoft. It’s always different.

    #354036 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    picture perfect
    45 pts
    @JasonADal

    With the results page, all I did was add the Vertical Scrolling to the default Results object on the page at the end of the test just like you would with any text box. Works like a dream in Firefox and Chrome.

    That’s why I’m so stumped about this not working in IE, despite how distant a planet Microsoft can be at times.

    And not EVERYTHING has to scroll – just everything that doesn’t fit into the course page size 🙂

     

     

    #354063 Score: 0
    Profile photo of Math Notermans
    Math Notermans
    Member
    contributor
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    LUC16 Attendee
    LUC16
    wise owl
    curious george
    119 pts
    @mnotermans5114

    Im sure i had vertical scrolling enabled on a textfield on a resultspage and it worked in IE11 too. Let me quickly doublecheck that though.

    #354075 Score: 0
    Profile photo of Adriana7707
    Adriana7707
    Member
    beginner
    intermediate
    curious george
    contributor
    wise owl
    @Adriana7707

    When you found out what is causing this, please let me know. I have this same problem, but in Moodle.

    #354102 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    picture perfect
    45 pts
    @JasonADal

    It’s not a separate text field, it’s the default results object that Lectora creates when you add the “Show Results” to the test properties. I did an inspect element on the results in IE as well as a scrolling text box as a comparison and found a very subtle difference.

    For the text box, buried way down in what I think are styles for the table it shows “-ms-overflow-y” whereas on the styles for the results, the setting is “overflow-y”. Both have auto as the value.

    I tried attaching a RunJS to it using document.get for the “otherXXXXX” (which is how it’s labeled in the html), but that didn’t seem to work either. I also thought about adding a class, but there’s no appearance setting to add a class to the results object.

    Other than creating a text box from scratch and adding each question individually to that text box, I’m not sure what other options I might have.

    #354111 Score: 0
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    profile
    199 pts
    @Klaatu

    Internet Explorer has a bug with overflow in that if a width for the element is not set it automatically sets overflow to visible. Visible does not clip the content and does not show scrollbars.

    #354113 Score: 0
    Profile photo of Tim K
    Tim K
    Member
    contributor
    beginner
    intermediate
    advanced
    friend finder
    junior moderator
    advocate
    wise owl
    curious george
    Group Member
    316 pts
    @timk

    It can be appended to a custom div:

    Create an HTML Extension of the type “Custom Div”. Give it a name with no numbers or blanks, e.g. “resultsdiv”. In difference to other Lectora objects, the name in the title explorer will be the ID of the Div.

    Create a second HTML Extension of the type “Meta Tags” and put in some CSS:

    
    
    <style>
    #resultsdiv{
    overflow: auto;
    clip: auto !important;
    }
    </style>
    
    

    Create a Run javascript action and insert:

    
    var tobeappended = document.getElementById("other1234");
    
    document.getElementById("resultsdiv").appendChild(tobeappended);
    #354290 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    picture perfect
    45 pts
    @JasonADal

    Tim, once again you lead me to the solution. I tried the settings from above and had this weird behavior where the value entered as the custom div displayed at the top of the page and the page itself was pretty much hosed.

    After some tinkering, I was able to get it to work with just a Custom Div and an OnShow attached to the element:

    Custom Div:

    <style>
    .resultsdiv {
    overflow: auto;
    clip: auto !important;
    }
    </style>

    RunJS on element:

    document.getElementById(“other383881”).className = “resultsdiv”;

    The scrolling now works in all browsers. I might be able to take some time this weekend to put together a sample to share – I don’t want to try and copy/paste my test to a new file, as is typical with my pages, there’s a lot of complexity 🙂

    #354388 Score: 0
    Profile photo of Deron Warman
    Deron Warman
    Member
    beginner
    intermediate
    friend finder
    curious george
    picture perfect
    contributor
    wise owl
    advanced
    profile
    verified member
    3 pts
    @DWarman

    I have asked this question to Trivantis on several occasions and have never received an answer (complete results not showing on “show results” test page, no way to scroll and get the correct button to close the popup).  Simple click of a button to show results and it didn’t work in IE for us either.  IE is our standard desktop enterprise wide so no option to go with Chrome or Firefox.

    Maybe you hit on something the software guys can fix/add with the “ms” not showing?

    Either way…I’ll copy your solution and test it in my courses.  I have been unselecting “show all” to just “incorrect”.  I still get questions though from students wanting to see the questions they got right (not sure why…you got it right!)?  I just tell them its a software issue and we are working it.

    This sounds like it solves it and maybe the programmers can fix the software in the next version?

    #354473 Score: 0
    Profile photo of Jason Dalrymple
    Jason Dalrymple
    Member
    beginner
    intermediate
    profile
    wise owl
    curious george
    contributor
    friend finder
    advanced
    picture perfect
    45 pts
    @JasonADal

    I’m not sure that this would work on the pop-up message that can be generated with the show results. The fix works if you have a page within a test where the results are on a box on that page in text format. Here’s a quick sample with 3 questions and the results object size reduced to show the scrolling effect.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.