Tagged: , , ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #295146 Score: 0
    Profile photo of robin.king
    robin.king
    Member
    beginner
    intermediate
    1 pt
    @robin.king

    I am inserting a skin for my audio control on each page of my title.  The audio is set to auto play.  The client has requested that if the “Mute” audio is selected on one slide, the mute setting persists on all the other slides.

    If I deselect auto play – they have to select to start the audio on every page.  Not what the client wants.

    Suggestions to get the mute setting to persist across slides?

    #295186 Score: 0
    Profile photo of Sergey Snegirev
    Sergey Snegirev
    Member
    contributor
    intermediate
    advanced
    friend finder
    lab member
    junior moderator
    advocate
    LUC16
    LUC16 Attendee
    wise owl
    336 pts
    @ssneg

    We usually don’t use skins and simply play the hidden audio with a custom button to mute/unmute it. The button has two actions:
    – if “muted_status” is “muted” UNMUTE else MUTE the audio
    – if “muted_status” is “muted” set it to “unmuted” ELSE set it to “muted”

    This will toggle both the media state and the control variable contents. Then we set all players to “NOT autoplay” and add an action to the page:
    – if “muted_status” is “unmuted” PLAY audio

    You could potentially do that by putting the above described transparent button on top of the player skin but I found out that the player seems to always be on top of everything, so you cannot click buttons on top of it.

    #295200 Score: 1
    Profile photo of Andrew Gaudet
    Andrew Gaudet
    Member
    beginner
    intermediate
    contributor
    verified member
    wise owl
    friend finder
    advanced
    10 pts
    @agaudet1236

    Was Talking to Daryl Fleary about this, and he put together a little sample title that can handle this type of situation.

    In the example he uses the play and pause actions, but these can be adjusted to use specifically the mute action.

    Below are the steps used in the example to address this

    First create a variable (In this example, I’ll call it “AudioPlay”)

    The Play, Pause, and Stop actions are specific to a particular audio file. So what you need to do is have a “placeholder” blank (no sound) audio file at the title (or chapter) level.  (The time length doesn’t matter.)  Also have the control button(s) for the audio file at the same level.

    The button actions should be:
    Play Placeholder Audio if AudioPlay=on, Else Pause Placeholder Audio (This is where you would do the mute else mute change).
    As the user clicks the button, update the variable.

    And on each page, have a Change Contents action to change the Placeholder audio to the actual audio file you want to hear.

     

     

    This post has received 1 vote up.
    • This reply was modified 4 years, 3 months ago by Profile photo of Andrew Gaudet Andrew Gaudet.
    #297278 Score: 0
    Profile photo of robin.king
    robin.king
    Member
    beginner
    intermediate
    1 pt
    @robin.king

    I have a similar issue.  I need to have the audio auto-play for all users except those using screen readers.  I want to have a button on the title page, that allows them to select “No Auto-play Audio”.  I cannot use an audio placeholder at the title level, because each audio file has events synced with it.

    I created a “noautoplay” variable and set the button on the title page to modify the variable to off.  Then on the audio file, I unchecked “auto-play” and added the following action:

    On Show Play

    If noautoplay = on

    Else pause

    However, the audio file plays whether the title page button to modify the variable is clicked or not.  Why doesn’t this work?

     

    #297323 Score: 0
    Profile photo of Andrew Gaudet
    Andrew Gaudet
    Member
    beginner
    intermediate
    contributor
    verified member
    wise owl
    friend finder
    advanced
    10 pts
    @agaudet1236

    I just tried this scenario out and was able to get it to work how you intended.

     

    For the noautoplay variable i had it default to “0”

    the on show action on pages where there are audio have the action : On show play if noautoplay = 0

    And then the button modifies the noautoplay to set it = to “1”

     

    I have attached a sample title that shows this behavior as I think you envisioned. Let me know if it works for you!

    Attachments:
    1. AudioAutoplay.pkg
    #297535 Score: 0
    Profile photo of robin.king
    robin.king
    Member
    beginner
    intermediate
    1 pt
    @robin.king

    Your title does exactly what I want, but doesn’t work in my title.  I think it may be that I am using a Lectora skin?

    #297545 Score: 0
    Profile photo of Andrew Gaudet
    Andrew Gaudet
    Member
    beginner
    intermediate
    contributor
    verified member
    wise owl
    friend finder
    advanced
    10 pts
    @agaudet1236

    Is the title something you could share with us?

    If you get in contact with support and let them know the situation and attach a pkg file I can take a look at it when it comes on through. It could be a couple of different thing’s so its pretty hard to track down.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.