Explore the community Forums Lectora Lectora Questions & Answers Space Between Bullet and Start of Text

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #310974 Score: 0
    Profile photo of jennifer butts
    jennifer butts
    Member
    beginner
    intermediate
    friend finder
    @jennifer butts

    For some reason the space between the bullets and the beginning of the text following a bullet is vary wide. I cannot find where to adjust this excessive space. When I publish the eBook and launch it from our LMS the space is so large as to be distracting and wrap text in an unfavorable way.

     

    Where can I fix this issue?

    #311067 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    114 pts
    @jvalley4735

    Have you updated your course to 16.1?  There was significant improvements made to make sure publishing courses with bullets and numbering is more consistent in the browser.

    #311091 Score: 0
    Profile photo of jennifer butts
    jennifer butts
    Member
    beginner
    intermediate
    friend finder
    @jennifer butts

    I have updated to the very newest release. When I insert a new text box they look OK, but the existing text boxes are seriously out of wack. It is hundreds of pages of an eBook and I don’t have the time or inclination to redo each box manually.

     

     

    #311186 Score: 1
    Profile photo of Darrel Somoza
    Darrel Somoza
    Member
    contributor
    friend finder
    beginner
    intermediate
    junior moderator
    advanced
    wise owl
    curious george
    profile
    199 pts
    @Klaatu

    Hi, Jennifer.

    I was away and didn’t see this until now. Here you go. Add a style sheet with the following rule.

    li[class^=’text’] {
    padding-left: 0!important;
    }

    How it works: The above rule says select all list items (li) that have an attribute (class) that begins with (^) the string “text” and assign it zero padding-left. The ‘!important’ is necessary because  unfortunately Lectora puts the style for bulleted text inline which has a higher priority than a user style sheet. Using !important is an override giving the rule the highest priority. Not good practice to generally use in regular web development because it breaks the cascade, but necessary in this case.

    By the way, this will style EVERY bulleted text in the project because all Lectora exported bulleted text are list items (li) with a class that begins with “text” (i.e. text38Font1). If you only want to target a specific instance another selector would be necessary.

    Oh, I almost forgot to mention, of course you can change the zero (0) padding-left to another number if zero is too close. I think the default is 8.

    Hope this helps.

    Darrel

    This post has received 1 vote up.
    #311254 Score: 0
    Profile photo of Jennifer Valley
    Jennifer Valley
    Member
    contributor
    beginner
    friend finder
    advanced
    lectora beginner
    verified member
    wise owl
    profile
    picture perfect
    curious george
    114 pts
    @jvalley4735

    That’s strange. Once you publish the bullets they should be showing up nicely in your LMS. Can you share your file? I’d love to take a look and possibly pass it along to our dev team.  What LMS are you using? Also what browser is it appearing off in?  Can you provide a screenshot?  Just trying to understand what your seeing.

    #326715 Score: 0
    Profile photo of SuzanneB
    SuzanneB
    Member
    beginner
    intermediate
    friend finder
    curious george
    wise owl
    contributor
    4 pts
    @SuzanneB

    Darrel’s explanation regarding the bullet indentation/padding spacing is very helpful. I have a related question regarding the line spacing between bullet items on a page. I created 1 text box with a paragraph of text followed by several bullet text items. I then copied the box and only changed some of the text in the second and third boxes. However, when I view the page (either via Run or Browser), I get different results. One of the boxes actually shows the way I see it when viewed in Edit mode. One of the boxes adds what appears to be multiple lines between the paragraph and the first bulleted item. So, I tried using the paragraph spacing option from the text formatting ribbon to reduce the line spacing after the paragraph from what appears to be a default 10 to 5. While that appeared to work in Edit mode, it was ignored when viewing. From Darrel’s explanation of the padding spacing, I assume the line spacing between bullets is overridden by the behind-the-scenes List Item code in Lectora. After searching further on the community, the two solutions I found to override the bullet line spacing are (1) create each bullet item as a separate text field or (2) use the “Convert to Image” option in the Text Properties ribbon. Is that correct, or is there a better way to do this?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.