Explore the community Forums Lectora Lectora Questions & Answers Spanish Closed Captioning

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #423436 Score: 0
    Profile photo of Jennifer Mohr
    Jennifer Mohr
    Member
    beginner
    intermediate
    friend finder
    picture perfect
    profile
    curious george
    wise owl
    contributor
    LUC17 Attendee
    1 pt
    @jmohr4076

    When I type Spanish accents into Notepad all looks perfect, but once the closed captioning is added to Lectora and the course is played, the accents are replaced with an odd question mark error symbol. Has anyone found a way around this? Our CEO is wanting this project done today, so I only have a few hours to work a miracle.

    Also, is there a way to make the CC option say Spanish instead of English at the bottom of the player?

    Thanks a ton for your help friends!

    #423439 Score: 0
    Profile photo of Stan Miller
    Stan Miller
    Member
    beginner
    intermediate
    LUC16 Attendee
    wise owl
    contributor
    curious george
    friend finder
    LUC17 Attendee
    35 pts
    @smiller7502

    Non-English closed caption files must specify the language in the filename. This should solve both problems, I think.

    For instance, if you are using .SRT files, the file naming convention is:

    <b>filename.[language code]_[country code].srt</b>

    Example: MyCaptions.es_LA.srt

    Here are the valid language-country code combinations for Spanish:
    <ul class=”uiList _1_ey _4kg _6-h _6-j _6-i”>
    <li class=”_1_ez”><b>es_CL</b> (Spanish – Chile)
    <li class=”_1_ez”><b>es_CO</b> (Spanish – Colombia)
    <li class=”_1_ez”><b>es_ES</b> (Spanish – Spain)
    <li class=”_1_ez”><b>es_LA</b> (Spanish)
    <li class=”_1_ez”><b>es_MX</b> (Spanish – Mexico)
    <li class=”_1_ez”><b>es_VE</b> (Spanish – Venezuela)

    Good luck!

    #423443 Score: 0
    Profile photo of Jennifer Mohr
    Jennifer Mohr
    Member
    beginner
    intermediate
    friend finder
    picture perfect
    profile
    curious george
    wise owl
    contributor
    LUC17 Attendee
    1 pt
    @jmohr4076

    Oh fantastic!! That explains a lot. You are a hero!

    My captions are in XML. Do you happen to know what should be entered for an XML version?

    #423445 Score: 0
    Profile photo of Stan Miller
    Stan Miller
    Member
    beginner
    intermediate
    LUC16 Attendee
    wise owl
    contributor
    curious george
    friend finder
    LUC17 Attendee
    35 pts
    @smiller7502

    I don’t, sorry. Wouldn’t be surprised if it’s the same, though.

    #423501 Score: 1
    Profile photo of sheryl coggins
    sheryl coggins
    Member
    LUC16 Attendee
    beginner
    intermediate
    profile
    verified member
    wise owl
    picture perfect
    contributor
    2 pts
    @scoggins3221

    When editing the Closed Caption files with non A-z characters in an text editor, be sure to save the files in Unicode / UTF-8 format.

    Microsoft Notepad uses ANSI by default.  When saving the first time, there is a format selector labeled ‘Encoding:’ next to the Save button.  Select Unicode, then Save.

    Other text editors offer the similar options, such as Notepad++ menu item Encoding offers several choices.

     

    This post has received 1 vote up.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.