Explore the community Forums Lectora Lectora Questions & Answers Strange characters in AWT file

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #281663 Score: 0
    Profile photo of adb
    adb
    Member
    @adb

    I had an AWT file containing a question and the AWT file contains

    …SP 9100DN…

    I changed the name of a completely unrelated chapter, saved the course and all of a sudden this file now contains

    …SP9100DN…

    It changed the original space to &#0xE;

    I’ve been using Java to read these AWT files as XML files, but that sequence breaks the file. It’s done it in several places. Any idea what’s going on?

    #284766 Score: 0
    Profile photo of adb
    adb
    Member
    @adb

    Anyone else played around with AWT files, treating them as XML or have you always used the XML variant?

    Well, I just exported an AWT file to XML and it converts all spaces between 2 particular words to  in elements. However, it leaves all other spaces between other words as spaces. After a bit more digging, I found it seems to be a problem with Lectora handling non-breaking spaces in the RTF elements

    For example there is a term “SP~9100DN” in the for questions and answers. ~ is an RTF non-breaking space. In the and elements, it’s just stored as a space. However, if you edit the course and save it, it leaves the ~ in the RTF OK. However, if that RTF is for the question text it then puts

    SP 9100DN

    and for answers, puts

    SP9100DN

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.