Explore the community Forums Lectora Lectora Questions & Answers Text boxes not showing unless outlined?? v12

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #297145 Score: 0
    Profile photo of agustav
    agustav
    Member
    friend finder
    beginner
    intermediate
    contributor
    LUC16 Attendee
    curious george
    wise owl
    3 pts
    @agustav

    I feel like I’m losing my mind. I decided to take a shot at using one of the new course starters to see how they work. When I add new text boxes to a page, they won’t show unless I add an outline or border to them. I’ve tried “always on top”, moving them to the bottom of the title explorer on their page–no luck. They have to be outlined in order to show on the page in run/preview, which would be fine if I wanted them outlined, but I don’t! Anyone else experienced this?

    #297175 Score: 0
    Profile photo of Wendy Miller
    Wendy Miller
    Member
    beginner
    intermediate
    contributor
    advanced
    friend finder
    junior moderator
    wise owl
    profile
    verified member
    55 pts
    @wendymiller

    Hi agustav,

    When you say “new course starters”, what exactly are you referring to? The themes built into Lectora maybe, or something else? I have not personally seen the issue that you’re describing with text boxes occur. Could you possibly attach the title you’re having trouble with?

    #297181 Score: 0
    Profile photo of agustav
    agustav
    Member
    friend finder
    beginner
    intermediate
    contributor
    LUC16 Attendee
    curious george
    wise owl
    3 pts
    @agustav

    I used one of the new course starters from the eLearning Brothers materials in Inspire Tools–really just wanted to see how they work. I attempted to attach the Lectora file I’m having the problem in, but not sure I did it correctly–it’s on the page called “Select Patient Account”. The text boxes aren’t showing when I preview the page–they are not set to “initially hidden” and there are no transitions on them, so I’m not sure why I’m not seeing them. I’m guessing it’s something about how these course starters are constructed, but I’m not seeing it (layering of the background image, maybe?).

    #297182 Score: 0
    Profile photo of Wendy Miller
    Wendy Miller
    Member
    beginner
    intermediate
    contributor
    advanced
    friend finder
    junior moderator
    wise owl
    profile
    verified member
    55 pts
    @wendymiller

    Hi agustav,

    You’ll need to make a zip file of your title before you try to upload it. Go to the File tab in Lectora and choose Export. Then choose Zip from the list on the right. Select the folder where you want to save the zip file and then click OK. This will ensure that all of the title resources are included.

     

    #297184 Score: 0
    Profile photo of agustav
    agustav
    Member
    friend finder
    beginner
    intermediate
    contributor
    LUC16 Attendee
    curious george
    wise owl
    3 pts
    @agustav

    Thanks for the instructions–haven’t done that before!

    #297188 Score: 0
    Profile photo of Wendy Miller
    Wendy Miller
    Member
    beginner
    intermediate
    contributor
    advanced
    friend finder
    junior moderator
    wise owl
    profile
    verified member
    55 pts
    @wendymiller

    Ok, I see what’s happening. Select one of those text boxes on that page and then go to the Style tab. You will see that the Margin Size is set to 11. That’s apparently too high for a text box of that size, so the text is getting pushed outside of the text box area at runtime. Try setting that to zero or at least a lower value.

    #297189 Score: 2
    Profile photo of Wendy Miller
    Wendy Miller
    Member
    beginner
    intermediate
    contributor
    advanced
    friend finder
    junior moderator
    wise owl
    profile
    verified member
    55 pts
    @wendymiller

    I spoke too soon. Setting the margin to zero does seem to fix the issue, but setting it to another lower value does not. I think I found the real culprit this time. Do you see the External HTML Object at the root of the title? Delete that and run that page again.

    That External HTML Object has a bit of CSS code in it that is no longer needed in Lectora 12 and is apparently incompatible with Lectora 12 text fields that have margins.

    This post has received 2 votes up.
    #297393 Score: 0
    Profile photo of agustav
    agustav
    Member
    friend finder
    beginner
    intermediate
    contributor
    LUC16 Attendee
    curious george
    wise owl
    3 pts
    @agustav

    Got it! Thanks so much for your help!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.